Browse files

Converted .gems to Gemfile so I can use my version of showoff.

  • Loading branch information...
1 parent 929cff4 commit a4d6981be5930e21c744466e97e1dd83ba2d1d1f @spraints committed Mar 25, 2010
Showing with 55 additions and 4 deletions.
  1. +0 −3 .gems
  2. +1 −0 .gitignore
  3. +6 −0 Gemfile
  4. +35 −0 Gemfile.lock
  5. +12 −0 brownbag-nosql.rb
  6. +1 −1 config.ru
View
3 .gems
@@ -1,3 +0,0 @@
-bluecloth
-nokogiri
-showoff
View
1 .gitignore
@@ -1 +1,2 @@
.*.swp
+.bundle
View
6 Gemfile
@@ -0,0 +1,6 @@
+source :rubygems
+gem 'bluecloth'
+gem 'nokogiri'
+
+git 'git://github.com/spraints/showoff.git'
+gem 'showoff'
View
35 Gemfile.lock
@@ -0,0 +1,35 @@
+---
+dependencies:
+ showoff:
+ group:
+ - :default
+ version: ">= 0"
+ bluecloth:
+ group:
+ - :default
+ version: ">= 0"
+ nokogiri:
+ group:
+ - :default
+ version: ">= 0"
+specs:
+- nokogiri:
+ version: 1.4.1
+- json:
+ version: 1.2.3
+- rack:
+ version: 1.1.0
+- sinatra:
+ version: "1.0"
+- bluecloth:
+ version: 2.0.7
+- showoff:
+ version: 0.1.1
+ source: 1
+hash: 0664663073dd6ebb5bbc475aa73bb5ed1ec78753
+sources:
+- Rubygems:
+ uri: http://gemcutter.org
+- Git:
+ uri: git://github.com/spraints/showoff.git
+ ref: 7dbdb17b451dd675d49f18a815b587a4e89adf06
View
12 brownbag-nosql.rb
@@ -0,0 +1,12 @@
+begin
+ # Require the preresolved locked set of gems.
+ require ::File.expand_path('../.bundle/environment', __FILE__)
+rescue LoadError
+ # Fallback on doing the resolve at runtime.
+ require "rubygems"
+ require "bundler"
+ Bundler.setup
+end
+
+require 'showoff'
+
View
2 config.ru
@@ -1,2 +1,2 @@
-require "showoff"
+require 'brownbag-nosql'
run ShowOff.new

0 comments on commit a4d6981

Please sign in to comment.