#6 still exist #9

Open
pyladune opened this Issue Jan 4, 2014 · 4 comments

Projects

None yet

4 participants

@pyladune

gem 'spree', github: 'spree/spree'
gem 'spree_auth_devise', github: 'spree/spree_auth_devise'
gem 'spree_fancy', :github => 'spree/spree_fancy'
gem 'spree_skrill', :git => 'git://github.com/spree/spree_skrill.git'

generates

/home/seb/.rbenv/versions/2.1.0-rc1/lib/ruby/gems/2.1.0/gems/activemodel-4.0.2/lib/active_model/deprecated_mass_assignment_security.rb:14:in attr_accessible':attr_accessibleis extracted out of Rails into a gem. Please use new recommended protection model for params(strong_parameters) or addprotected_attributesto your Gemfile to use old one. (RuntimeError)
from /home/seb/.rbenv/versions/2.1.0-rc1/lib/ruby/gems/2.1.0/bundler/gems/spree_skrill-d0efa3e6ddb0/app/models/spree/billing_integration/skrill/quick_checkout.rb:8:in
class:QuickCheckout'

thanks

@clemens

You're using Rails 4 which doesn't come with attr_accessible out of the box. To continue using versions of Spree and extensions that use attr_accessible you must add the protected_attributes gem – just as the error message indicates.

@seanrclayton

Having this issue myself, looks like spree no longer supports the protected_attributes gem:

[FATAL] Spree does not work with the protected_attributes gem installed!
You MUST remove this gem from your Gemfile. It is incompatible with Spree.

@JDutil
spree-contrib member

I think this project was merged into spree_gateway you should try using skrill that way.

@seanrclayton

Thanks, yes I got it working.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment