Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

rolled back spree and rails, fixed deploy bug

  • Loading branch information...
commit b6c91865f01e1ee4bbecd810fbab18035734f16a 1 parent 4eb687f
@cmar cmar authored
Showing with 136 additions and 137 deletions.
  1. +5 −4 Gemfile
  2. +130 −132 Gemfile.lock
  3. +1 −1  config/deploy.rb
View
9 Gemfile
@@ -3,7 +3,7 @@ source 'http://rubygems.org'
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
-gem 'rails', '3.1.1'
+gem 'rails', '3.1.0'
gem 'aws-s3'
gem 'hoptoad_notifier'
@@ -28,9 +28,9 @@ gem 'spree_rdr_theme', :git => 'git://github.com/spree/spree_rdr_theme.git'
gem 'capistrano'
group :assets do
- gem 'sass-rails', '~> 3.1.4'
- gem 'coffee-rails', '~> 3.1.1'
- gem 'uglifier', '>= 1.0.3'
+ gem 'sass-rails', "~> 3.1.0"
+ gem 'coffee-rails', "~> 3.1.0"
+ gem 'uglifier'
end
group :development, :test do
@@ -53,3 +53,4 @@ group :production do
end
gem 'deface', :git => 'git://github.com/railsdog/deface.git'
+
View
262 Gemfile.lock
@@ -8,88 +8,88 @@ GIT
GIT
remote: git://github.com/railsdog/deface.git
- revision: c3a86655f5639d0d4c33fa56a3bd3595ce76880c
+ revision: 98941182cdf89474c19594cd8337a3777bb39dc1
specs:
- deface (0.7.0)
+ deface (0.6.1)
nokogiri (~> 1.5.0)
rails (>= 3.0.9)
GIT
remote: git://github.com/spree/spree.git
- revision: bb2831b159d39f3199f143d65f3e9ae0bff7aaa8
+ revision: 8e9feaa6dfc908d45fca57c301950cfe4a58a611
specs:
- spree (0.70.0)
- spree_api (= 0.70.0)
- spree_auth (= 0.70.0)
- spree_core (= 0.70.0)
- spree_dash (= 0.70.0)
- spree_promo (= 0.70.0)
- spree_sample (= 0.70.0)
- spree_api (0.70.0)
- spree_auth (= 0.70.0)
- spree_core (= 0.70.0)
- spree_auth (0.70.0)
+ spree (0.70.RC1)
+ spree_api (= 0.70.RC1)
+ spree_auth (= 0.70.RC1)
+ spree_core (= 0.70.RC1)
+ spree_dash (= 0.70.RC1)
+ spree_promo (= 0.70.RC1)
+ spree_sample (= 0.70.RC1)
+ spree_api (0.70.RC1)
+ spree_auth (= 0.70.RC1)
+ spree_core (= 0.70.RC1)
+ spree_auth (0.70.RC1)
cancan (= 1.6.5)
- devise (= 1.4.7)
- spree_core (= 0.70.0)
- spree_core (0.70.0)
+ devise (= 1.4.4)
+ spree_core (= 0.70.RC1)
+ spree_core (0.70.RC1)
activemerchant (= 1.17.0)
acts_as_list (= 0.1.4)
- deface (>= 0.7.0)
- faker (= 1.0.0)
- highline (= 1.6.2)
- jquery-rails (>= 1.0.14)
+ deface (>= 0.6.1)
+ faker (= 0.9.5)
+ highline (= 1.5.1)
+ jquery-rails (>= 1.0.13)
kaminari (>= 0.12.4)
meta_search (= 1.1.1)
nested_set (= 1.6.8)
paperclip (= 2.4.1)
- rails (= 3.1.1)
+ rails (= 3.1.0)
rd_find_by_param (= 0.1.1)
rd_resource_controller
state_machine (= 1.0.1)
stringex (= 1.0.3)
- spree_dash (0.70.0)
- spree_core (= 0.70.0)
- spree_promo (0.70.0)
- spree_auth (= 0.70.0)
- spree_core (= 0.70.0)
- spree_sample (0.70.0)
- spree_core (= 0.70.0)
+ spree_dash (0.70.RC1)
+ spree_core (= 0.70.RC1)
+ spree_promo (0.70.RC1)
+ spree_auth (= 0.70.RC1)
+ spree_core (= 0.70.RC1)
+ spree_sample (0.70.RC1)
+ spree_core (= 0.70.RC1)
GIT
remote: git://github.com/spree/spree_active_shipping.git
- revision: a59b4eb9a16d95edc122b86e04c26df188887243
+ revision: b32c7ecf4f8b71a00e5f6a662665fcbe6a16091e
specs:
- spree_active_shipping (1.1.0)
+ spree_active_shipping (1.0.3)
active_shipping (= 0.9.13)
- spree_core (>= 0.70.0)
+ spree_core (>= 0.30.1)
GIT
remote: git://github.com/spree/spree_editor.git
- revision: 4450053172bacafcec79120d3ffe013573db2aa9
+ revision: b7e4c0000366376bc111f9ffc8c2faac5548334d
specs:
spree_editor (0.50.1)
spree_core (>= 0.40.0)
GIT
remote: git://github.com/spree/spree_email_to_friend.git
- revision: aa68252f46eebe63243ea417b69f1bc1cb149d10
+ revision: deee959568ac53004ddfcc18253c9c966a70ba44
specs:
spree_email_to_friend (1.2)
recaptcha (>= 0.3.1)
- spree_auth (>= 0.70.0)
- spree_core (>= 0.70.0)
+ spree_auth (>= 0.30.1)
+ spree_core (>= 0.30.1)
GIT
remote: git://github.com/spree/spree_paypal_express.git
- revision: bea1aa48e0089083546bec4b19565a40e9a50a20
+ revision: 4dadc4ad67d52613f136cfda57ff291f5c2daf77
specs:
spree_paypal_express (1.0.1)
spree_core (>= 0.40.3)
GIT
remote: git://github.com/spree/spree_rdr_theme.git
- revision: 263a0a4ccf7a10b65c21aed2dd885260f40464dc
+ revision: 050d729a767b82b560155efb1cf54c4ed2d709d7
specs:
spree_rdr_theme (0.1.0)
@@ -111,15 +111,15 @@ GIT
GIT
remote: git://github.com/spree/spree_social.git
- revision: 1a99e011a44ce1aeaf73103e83ed873df82cb490
+ revision: ab0293d3ae77365bb46357074baeb551cefdca3e
specs:
spree_social (1.3)
- oa-oauth (>= 0.3.2)
+ oa-oauth (>= 0.2.6)
spree_auth (>= 0.60.1)
GIT
remote: git://github.com/spree/spree_static_content.git
- revision: 50168594c51ee370853ba2d9b4b1b9d704a8b74a
+ revision: be324454310714634545bbb9d79ae03c2f66dca8
specs:
spree_static_content (0.60.2)
formtastic (~> 2.0.0.rc5)
@@ -144,38 +144,39 @@ GIT
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.1)
- actionpack (= 3.1.1)
+ actionmailer (3.1.0)
+ actionpack (= 3.1.0)
mail (~> 2.3.0)
- actionpack (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
+ actionpack (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
builder (~> 3.0.0)
erubis (~> 2.7.0)
i18n (~> 0.6)
rack (~> 1.3.2)
- rack-cache (~> 1.1)
+ rack-cache (~> 1.0.3)
rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.0.2)
+ sprockets (~> 2.0.0)
activemerchant (1.17.0)
activesupport (>= 2.3.11)
braintree (>= 2.0.0)
builder (>= 2.0.0)
json (>= 1.5.1)
- activemodel (3.1.1)
- activesupport (= 3.1.1)
+ activemodel (3.1.0)
+ activesupport (= 3.1.0)
+ bcrypt-ruby (~> 3.0.0)
builder (~> 3.0.0)
i18n (~> 0.6)
- activerecord (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
+ activerecord (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
arel (~> 2.2.1)
tzinfo (~> 0.3.29)
- activeresource (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- activesupport (3.1.1)
+ activeresource (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ activesupport (3.1.0)
multi_json (~> 1.0)
acts_as_list (0.1.4)
addressable (2.2.6)
@@ -185,11 +186,11 @@ GEM
mime-types
xml-simple
bcrypt-ruby (3.0.1)
- braintree (2.12.0)
+ braintree (2.11.0)
builder (>= 2.0.0)
builder (3.0.0)
cancan (1.6.5)
- capistrano (2.9.0)
+ capistrano (2.8.0)
highline
net-scp (>= 1.0.0)
net-sftp (>= 2.0.0)
@@ -204,7 +205,7 @@ GEM
rack-test (>= 0.5.4)
selenium-webdriver (>= 0.0.27)
xpath (~> 0.1.2)
- celerity (0.9.1)
+ celerity (0.9.0)
childprocess (0.2.2)
ffi (~> 1.0.6)
cocaine (0.2.0)
@@ -216,10 +217,10 @@ GEM
execjs
coffee-script-source (1.1.2)
columnize (0.3.4)
- cucumber (1.1.0)
+ cucumber (1.0.6)
builder (>= 2.1.2)
diff-lcs (>= 1.1.2)
- gherkin (~> 2.5.0)
+ gherkin (~> 2.4.18)
json (>= 1.4.6)
term-ansicolor (>= 1.0.6)
cucumber-rails (0.4.1)
@@ -228,44 +229,43 @@ GEM
rack-test (>= 0.5.7)
culerity (0.2.15)
database_cleaner (0.6.7)
- devise (1.4.7)
+ devise (1.4.4)
bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.0.3)
warden (~> 1.0.3)
diff-lcs (1.1.3)
erubis (2.7.0)
- execjs (1.2.9)
+ execjs (1.2.6)
multi_json (~> 1.0)
- factory_girl (2.2.0)
- activesupport
- factory_girl_rails (1.3.0)
- factory_girl (~> 2.2.0)
+ factory_girl (2.1.0)
+ factory_girl_rails (1.2.0)
+ factory_girl (~> 2.1.0)
railties (>= 3.0.0)
- faker (1.0.0)
+ faker (0.9.5)
i18n (~> 0.4)
- faraday (0.7.5)
- addressable (~> 2.2.6)
- multipart-post (~> 1.1.3)
+ faraday (0.6.1)
+ addressable (~> 2.2.4)
+ multipart-post (~> 1.1.0)
rack (>= 1.1.0, < 2)
ffi (1.0.9)
- foreman (0.25.0)
+ foreman (0.22.0)
term-ansicolor (~> 1.0.5)
thor (>= 0.13.6)
- formtastic (2.0.2)
+ formtastic (2.0.0.rc5)
rails (~> 3.0)
- gherkin (2.5.4)
+ gherkin (2.4.18)
json (>= 1.4.6)
- highline (1.6.2)
+ highline (1.5.1)
hike (1.2.1)
hoptoad_notifier (2.4.11)
activesupport
builder
i18n (0.6.0)
- jquery-rails (1.0.16)
+ jquery-rails (1.0.14)
railties (~> 3.0)
thor (~> 0.14)
- json (1.6.1)
- json_pure (1.6.1)
+ json (1.6.0)
+ json_pure (1.6.0)
kaminari (0.12.4)
rails (>= 3.0.0)
kgio (2.6.0)
@@ -283,9 +283,9 @@ GEM
activerecord (~> 3.1.0)
activesupport (~> 3.1.0)
polyamorous (~> 0.5.0)
- mime-types (1.17.2)
+ mime-types (1.16)
multi_json (1.0.3)
- multi_xml (0.4.1)
+ multi_xml (0.2.2)
multipart-post (1.1.3)
mysql2 (0.3.7)
nested_set (1.6.8)
@@ -298,20 +298,20 @@ GEM
net-ssh (2.2.1)
net-ssh-gateway (1.1.0)
net-ssh (>= 1.99.1)
- newrelic_rpm (3.2.0)
+ newrelic_rpm (3.1.2)
nokogiri (1.5.0)
- oa-core (0.3.2)
- oa-oauth (0.3.2)
- faraday (~> 0.7.3)
+ oa-core (0.2.6)
+ oa-oauth (0.2.6)
+ faraday (~> 0.6.1)
multi_json (~> 1.0.0)
- multi_xml (~> 0.4.0)
- oa-core (= 0.3.2)
+ multi_xml (~> 0.2.2)
+ oa-core (= 0.2.6)
oauth (~> 0.4.0)
- oauth2 (~> 0.5.0)
+ oauth2 (~> 0.4.1)
oauth (0.4.5)
- oauth2 (0.5.1)
- faraday (~> 0.7.4)
- multi_json (~> 1.0.3)
+ oauth2 (0.4.1)
+ faraday (~> 0.6.1)
+ multi_json (>= 0.0.5)
orm_adapter (0.0.5)
paperclip (2.4.1)
activerecord (>= 2.3.0)
@@ -321,8 +321,8 @@ GEM
polyamorous (0.5.0)
activerecord (~> 3.0)
polyglot (0.3.2)
- rack (1.3.5)
- rack-cache (1.1)
+ rack (1.3.2)
+ rack-cache (1.0.3)
rack (>= 0.4)
rack-mount (0.8.3)
rack (>= 1.0.0)
@@ -330,90 +330,88 @@ GEM
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.1)
- actionmailer (= 3.1.1)
- actionpack (= 3.1.1)
- activerecord (= 3.1.1)
- activeresource (= 3.1.1)
- activesupport (= 3.1.1)
+ rails (3.1.0)
+ actionmailer (= 3.1.0)
+ actionpack (= 3.1.0)
+ activerecord (= 3.1.0)
+ activeresource (= 3.1.0)
+ activesupport (= 3.1.0)
bundler (~> 1.0)
- railties (= 3.1.1)
- railties (3.1.1)
- actionpack (= 3.1.1)
- activesupport (= 3.1.1)
+ railties (= 3.1.0)
+ railties (3.1.0)
+ actionpack (= 3.1.0)
+ activesupport (= 3.1.0)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
- raindrops (0.8.0)
- rake (0.9.2.2)
+ raindrops (0.7.0)
+ rake (0.9.2)
rbx-require-relative (0.0.5)
rd_find_by_param (0.1.1)
activerecord (~> 3.0)
activesupport (~> 3.0)
rd_resource_controller (1.0.1)
- rdoc (3.11)
- json (~> 1.4)
+ rdoc (3.9.4)
recaptcha (0.3.1)
rest-client (1.6.7)
mime-types (>= 1.16)
- rspec (2.7.0)
- rspec-core (~> 2.7.0)
- rspec-expectations (~> 2.7.0)
- rspec-mocks (~> 2.7.0)
- rspec-core (2.7.1)
- rspec-expectations (2.7.0)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
diff-lcs (~> 1.1.2)
- rspec-mocks (2.7.0)
- rspec-rails (2.7.0)
+ rspec-mocks (2.6.0)
+ rspec-rails (2.6.1)
actionpack (~> 3.0)
activesupport (~> 3.0)
railties (~> 3.0)
- rspec (~> 2.7.0)
+ rspec (~> 2.6.0)
ruby-debug (0.10.4)
columnize (>= 0.1)
ruby-debug-base (~> 0.10.4.0)
ruby-debug-base (0.10.4)
linecache (>= 0.3)
rubyzip (0.9.4)
- sass (3.1.10)
- sass-rails (3.1.4)
+ sass (3.1.7)
+ sass-rails (3.1.1)
actionpack (~> 3.1.0)
railties (~> 3.1.0)
sass (>= 3.1.4)
- sprockets (~> 2.0.0)
tilt (~> 1.3.2)
- selenium-webdriver (2.9.1)
+ selenium-webdriver (2.6.0)
childprocess (>= 0.2.1)
- ffi (= 1.0.9)
+ ffi (>= 1.0.7)
json_pure
rubyzip
- sprockets (2.0.3)
+ sprockets (2.0.0)
hike (~> 1.2)
rack (~> 1.0)
tilt (!= 1.3.0, ~> 1.1)
sqlite3 (1.3.4)
state_machine (1.0.1)
stringex (1.0.3)
- term-ansicolor (1.0.7)
- therubyracer (0.9.8)
+ term-ansicolor (1.0.6)
+ therubyracer (0.9.4)
libv8 (~> 3.3.10)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.30)
- uglifier (1.0.4)
+ tzinfo (0.3.29)
+ uglifier (1.0.3)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
unicorn (4.1.1)
kgio (~> 2.4)
rack
raindrops (~> 0.6)
- warden (1.0.6)
+ warden (1.0.5)
rack (>= 1.0)
- xml-simple (1.1.1)
+ xml-simple (1.1.0)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -425,7 +423,7 @@ DEPENDENCIES
aws-s3
capistrano
capybara (= 0.4.0)
- coffee-rails (~> 3.1.1)
+ coffee-rails (~> 3.1.0)
cucumber-rails (>= 0.3.2)
database_cleaner
deface!
@@ -435,10 +433,10 @@ DEPENDENCIES
launchy (>= 0.3.7)
mysql2
newrelic_rpm
- rails (= 3.1.1)
+ rails (= 3.1.0)
rspec-rails (>= 2.0.1)
ruby-debug
- sass-rails (~> 3.1.4)
+ sass-rails (~> 3.1.0)
spree!
spree_active_shipping!
spree_analytics!
@@ -453,5 +451,5 @@ DEPENDENCIES
spree_wishlist!
sqlite3
therubyracer
- uglifier (>= 1.0.3)
+ uglifier
unicorn
View
2  config/deploy.rb
@@ -51,7 +51,7 @@
desc "Symlink shared configs and folders on each release."
task :symlink_shared do
run "ln -nfs #{shared_path}/config/database.yml #{release_path}/config/database.yml"
- run "ln -nfs #{shared_path}/config/s3.yml #{release_path}/config/database.yml"
+ run "ln -nfs #{shared_path}/config/s3.yml #{release_path}/config/s3.yml"
run "ln -nfs #{shared_path}/config/Procfile #{release_path}/Procfile"
end
Please sign in to comment.
Something went wrong with that request. Please try again.