Skip to content
This repository
Browse code

lockdown the gem version

  • Loading branch information...
commit 8f2f618638d8d589479c1668ecc761ff8c6e7b0b 1 parent fd40985
Neeraj Singh authored January 13, 2011 schof committed January 13, 2011
2  auth/spree_auth.gemspec
@@ -19,5 +19,5 @@ Gem::Specification.new do |s|
19 19
 
20 20
   s.add_dependency('spree_core',  version)
21 21
   s.add_dependency('devise', '= 1.2.rc')
22  
-  s.add_dependency('cancan', '>= 1.3.3')
  22
+  s.add_dependency('cancan', '= 1.3.3')
23 23
 end
26  core/spree_core.gemspec
@@ -17,20 +17,20 @@ Gem::Specification.new do |s|
17 17
   s.require_path = 'lib'
18 18
   s.requirements << 'none'
19 19
 
20  
-  s.add_dependency('acts_as_list', '>= 0.1.2')
21  
-  s.add_dependency('rd_awesome_nested_set', '>= 1.4.4')
22  
-  s.add_dependency('rd_unobtrusive_date_picker', '>= 0.1.0')
  20
+  s.add_dependency('acts_as_list', '= 0.1.2')
  21
+  s.add_dependency('rd_awesome_nested_set', '= 1.4.4')
  22
+  s.add_dependency('rd_unobtrusive_date_picker', '= 0.1.0')
23 23
 
24  
-  s.add_dependency('highline', '>= 1.5.1')
  24
+  s.add_dependency('highline', '= 1.5.1')
25 25
   #s.add_dependency('less', '>= 1.2.20')
26  
-  s.add_dependency('stringex', '>= 1.0.3')
27  
-  s.add_dependency('state_machine', '>= 0.9.4')
28  
-  s.add_dependency('faker', '>= 0.3.1')
29  
-  s.add_dependency('paperclip', '>= 2.3.1.1')
  26
+  s.add_dependency('stringex', '= 1.0.3')
  27
+  s.add_dependency('state_machine', '= 0.9.4')
  28
+  s.add_dependency('faker', '= 0.9.4')
  29
+  s.add_dependency('paperclip', '= 2.3.8')
30 30
   s.add_dependency('rd_resource_controller')
31  
-  s.add_dependency('rd_searchlogic', '>= 3.0.0')
32  
-  s.add_dependency('activemerchant', '>= 1.7.1')
33  
-  s.add_dependency('will_paginate', '>= 3.0.pre2')
34  
-  s.add_dependency('rails', '>= 3.0.3')
35  
-  s.add_dependency('jquery-rails', '>= 0.2.2')
  31
+  s.add_dependency('rd_searchlogic', '= 3.0.0')
  32
+  s.add_dependency('activemerchant', '= 1.7.1')
  33
+  s.add_dependency('will_paginate', '= 3.0.pre2')
  34
+  s.add_dependency('rails', '= 3.0.3')
  35
+  s.add_dependency('jquery-rails', '= 0.2.2')
36 36
 end

0 notes on commit 8f2f618

Please sign in to comment.
Something went wrong with that request. Please try again.