Could not find gem 'spree (= 1.1.0) ruby' in the gems available on this machine. #1444

Closed
mmcc opened this Issue Apr 25, 2012 · 6 comments

Comments

Projects
None yet
3 participants
@mmcc

mmcc commented Apr 25, 2012

I'm having a myriad of issues creating a new Spree project and it seems like every method is causing problems. Rails 3.2.3 was already installed on the system. gem install spree gave me the dependency issue, so I installed spree_cmd.

Try 1

rails new project
spree install project

I accept all defaults and then get this error:

run  bundle install from "./project"
Could not find gem 'spree_skrill (>= 0) ruby' in the gems available on this machine.
Run `bundle install` to install missing gems.
precompiling  assets
Could not find gem 'spree_skrill (>= 0) ruby' in the gems available on this machine.
Run `bundle install` to install missing gems.

So I cd into the directory and run bundle install only to get this error:

Bundler could not find compatible versions for gem "jquery-rails":
    In Gemfile:
        spree_usa_epay (>= 0) ruby depends on
            jquery-rails (<= 1.0.19, >= 1.0.18) ruby

        jquery-rails (2.0.2)

I'm not really interested in the default payment gateways anyway, so I go ahead and move on to try 2 where I won't bother with the default gateways. I realize at this point I could just remove the gateways from the gemfile, but for the issue's sake I'm going to keep everything consistent and regenerate.

Try 2 (without default gateways)

rails new project2
spree install project2

This time I said no to the default gateways and yes to everything else, only to get this error:

ActiveRecord::ConnectionNotEstablished

A quick glance says it's because for some reason Bundler is trying to install Spree 0.40.0, so let's move on to try 3 where I'll go with adding everything to the Gemfile with explicit version numbers.

Try 3 (manually adding to gemfile)

rails new project3

Add spree to the Gemfile with an explicit version number.

gem 'spree', '1.1.0'

Run bundle install and.....

Could not find gem 'spree (= 1.1.0) ruby' in the gems available on this machine.

And that's the end of the road. The last version of Spree I installed was right after 1 was released and I had no problems at all.

@radar

This comment has been minimized.

Show comment
Hide comment
@radar

radar Apr 25, 2012

Member

Spree 1.1.0 has not been released. Please try using the release candidate. 1.1.0.rc2.

On 25/04/2012, at 10:31 AM, Matthew McClurereply@reply.github.com wrote:

I'm having a myriad of issues creating a new Spree project and it seems like every method is causing problems. Rails 3.2.3 was already installed on the system. gem install spree gave me the dependency issue, so I installed spree_cmd.

Try 1

rails new project
spree install project

I accept all defaults and then get this error:

run bundle install from "./project"
Could not find gem 'spree_skrill (>= 0) ruby' in the gems available on this machine.
Run bundle install to install missing gems.
precompiling assets
Could not find gem 'spree_skrill (>= 0) ruby' in the gems available on this machine.
Run bundle install to install missing gems.

So I cd into the directory and run bundle install only to get this error:

Bundler could not find compatible versions for gem "jquery-rails":
In Gemfile:
spree_usa_epay (>= 0) ruby depends on
jquery-rails (<= 1.0.19, >= 1.0.18) ruby

       jquery-rails (2.0.2)

I'm not really interested in the default payment gateways anyway, so I go ahead and move on to try 2 where I won't bother with the default gateways. I realize at this point I could just remove the gateways from the gemfile, but for the issue's sake I'm going to keep everything consistent and regenerate.

Try 2 (without default gateways)

rails new project2
spree install project2

This time I said no to the default gateways and yes to everything else, only to get this error:

ActiveRecord::ConnectionNotEstablished

A quick glance says it's because for some reason Bundler is trying to install Spree 0.40.0, so let's move on to try 3 where I'll go with adding everything to the Gemfile with explicit version numbers.

Try 3 (manually adding to gemfile)

rails new project3

Add spree to the Gemfile with an explicit version number.

gem 'spree', '1.1.0'

Run bundle install and.....

Could not find gem 'spree (= 1.1.0) ruby' in the gems available on this machine.

And that's the end of the road. The last version of Spree I installed was right after 1 was released and I had no problems at all.


Reply to this email directly or view it on GitHub:
#1444

Member

radar commented Apr 25, 2012

Spree 1.1.0 has not been released. Please try using the release candidate. 1.1.0.rc2.

On 25/04/2012, at 10:31 AM, Matthew McClurereply@reply.github.com wrote:

I'm having a myriad of issues creating a new Spree project and it seems like every method is causing problems. Rails 3.2.3 was already installed on the system. gem install spree gave me the dependency issue, so I installed spree_cmd.

Try 1

rails new project
spree install project

I accept all defaults and then get this error:

run bundle install from "./project"
Could not find gem 'spree_skrill (>= 0) ruby' in the gems available on this machine.
Run bundle install to install missing gems.
precompiling assets
Could not find gem 'spree_skrill (>= 0) ruby' in the gems available on this machine.
Run bundle install to install missing gems.

So I cd into the directory and run bundle install only to get this error:

Bundler could not find compatible versions for gem "jquery-rails":
In Gemfile:
spree_usa_epay (>= 0) ruby depends on
jquery-rails (<= 1.0.19, >= 1.0.18) ruby

       jquery-rails (2.0.2)

I'm not really interested in the default payment gateways anyway, so I go ahead and move on to try 2 where I won't bother with the default gateways. I realize at this point I could just remove the gateways from the gemfile, but for the issue's sake I'm going to keep everything consistent and regenerate.

Try 2 (without default gateways)

rails new project2
spree install project2

This time I said no to the default gateways and yes to everything else, only to get this error:

ActiveRecord::ConnectionNotEstablished

A quick glance says it's because for some reason Bundler is trying to install Spree 0.40.0, so let's move on to try 3 where I'll go with adding everything to the Gemfile with explicit version numbers.

Try 3 (manually adding to gemfile)

rails new project3

Add spree to the Gemfile with an explicit version number.

gem 'spree', '1.1.0'

Run bundle install and.....

Could not find gem 'spree (= 1.1.0) ruby' in the gems available on this machine.

And that's the end of the road. The last version of Spree I installed was right after 1 was released and I had no problems at all.


Reply to this email directly or view it on GitHub:
#1444

@radar radar closed this Apr 25, 2012

@mmcc

This comment has been minimized.

Show comment
Hide comment
@mmcc

mmcc Apr 25, 2012

That fixed it, but the readme should be updated to reflect that as it currently says add gem 'spree', '1.1.0' to the Gemfile.

mmcc commented Apr 25, 2012

That fixed it, but the readme should be updated to reflect that as it currently says add gem 'spree', '1.1.0' to the Gemfile.

@radar

This comment has been minimized.

Show comment
Hide comment
@radar

radar Apr 25, 2012

Member

The master branch, which is the README that you are reading, contains work for the future version of Spree. If you are intending to use 1-1-stable then you should read the README from that branch.

Member

radar commented Apr 25, 2012

The master branch, which is the README that you are reading, contains work for the future version of Spree. If you are intending to use 1-1-stable then you should read the README from that branch.

@mmcc

This comment has been minimized.

Show comment
Hide comment
@mmcc

mmcc Apr 25, 2012

forehead slap

mmcc commented Apr 25, 2012

forehead slap

@radar

This comment has been minimized.

Show comment
Hide comment
@radar

radar Apr 25, 2012

Member

Updated the README to stop people coming across this issue.

Member

radar commented Apr 25, 2012

Updated the README to stop people coming across this issue.

@antonywu

This comment has been minimized.

Show comment
Hide comment
@antonywu

antonywu Apr 27, 2012

Well, I ran into the similar issue, except this time, I was reading from the 1.1 Stable branch.
https://github.com/spree/spree/tree/1-1-stable

So I am glad sh1ps asked the question.

Well, I ran into the similar issue, except this time, I was reading from the 1.1 Stable branch.
https://github.com/spree/spree/tree/1-1-stable

So I am glad sh1ps asked the question.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment