Skip to content
This repository

Bump Paperclip to the latest version? #1653

Closed
alexdowad opened this Issue · 6 comments

3 participants

Alex Dowad Ryan Bigg John Gadbois
Alex Dowad

I have a client running a Spree-based web store, who is having problems adding product images. His images are stored on Amazon S3, and the upload is failing with the following error message:

Your socket connection to the server was not read from or written to within the timeout period. Idle connections will be closed.
/home/deployer/madjungle.co.uk/shared/bundle/ruby/1.9.1/gems/aws-sdk-1.3.9/lib/aws/core/client.rb:277:in `return_or_raise'
/home/deployer/madjungle.co.uk/shared/bundle/ruby/1.9.1/gems/aws-sdk-1.3.9/lib/aws/core/client.rb:362:in `client_request'
(eval):3:in `put_object'
...

According to this page: thoughtbot/paperclip#751, this problem was fixed in Paperclip 3.0.2. But Spree requires Paperclip ~> 2.7, which excludes 3.0.2. Is there any reason not to use the latest version of Paperclip? Is it incompatible with anything in Spree? If so, and someone can point me to the incompatibilities, I may be able to code up a patch to make Spree compatible with the latest version of Paperclip.

Ryan Bigg
Collaborator
radar commented

We're not using the 3.x branch of Paperclip because it means that we would no longer be able to offer Ruby 1.8 support in Spree. We are going to drop Ruby 1.8 support when Rails does.

It's unfortunate that Paperclip didn't backport this patch to 2.7, but we can understand why. Perhaps we can relax the dependency?

Alex Dowad

Hmm. If you change ~> 2.7 to >= 2.7, I presume "bundle install" will be broken for Ruby 1.8 users, as Bundler will go for the newest version. This is a tricky one...

Ryan Bigg
Collaborator
radar commented

Yup, that's right.

We can definitely relax it to allow 3.0.2 on systems that have Ruby 1.9 installed, but then we need to explain to people who are using 1.8 that they run into this problem.

This is definitely a paperclip issue, and I can see that you've posted here about it, and so this issue will be fixed when the next 2.7 release is out.

Ryan Bigg
Collaborator
radar commented

I saw your comment in email ;)

Aha, but there is still a ray of hope shining through the darkness... thoughtbot/paperclip#751 (comment)

Indeed! @sikachu rocks!

Alex Dowad alexdowad closed this
John Gadbois

@radar - is allowing 3.0.2 still an option or are you just going to have users use the (eventually) backported 2.7? I'm using 3.0.2 in a project and would like to be able to use it with Spree

Ryan Bigg
Collaborator
radar commented

@jgadbois If we didn't have to support Ruby 1.8, Spree would be using 3.0.2. Until then, we are still forced to use 2.7.

Also, I don't know if Paperclip 3 would cause anything in Spree to break or not.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.