New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RMA Process: Order Status does not update. #1714

Closed
ghost opened this Issue Jun 25, 2012 · 6 comments

Comments

Projects
None yet
3 participants
@ghost

ghost commented Jun 25, 2012

I am currently evaluating Spree commerce and using the stable 1.1.1 branch.

I'd like to get some clarification on the RMA process out of the box. After completing the process, marking the RMA mechandise as received and issue the refund. The order status appears to get stuck in "awaiting return". Am I missing something or is this a bug?

@joneslee85

This comment has been minimized.

Show comment
Hide comment
@joneslee85

joneslee85 Jun 25, 2012

Member

@RafaelUbaldo likely a bug, are you testing it on sandbox?

Member

joneslee85 commented Jun 25, 2012

@RafaelUbaldo likely a bug, are you testing it on sandbox?

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jun 25, 2012

I've installed Spree into a freshly created application. I've duplicated it on master using the sandbox. I'm not that familiar with the project codebase. Any tips would be appreciated. We may want to use a custom spree version with the amount of apparent quarks I am finding.

I am looking into it.

ghost commented Jun 25, 2012

I've installed Spree into a freshly created application. I've duplicated it on master using the sandbox. I'm not that familiar with the project codebase. Any tips would be appreciated. We may want to use a custom spree version with the amount of apparent quarks I am finding.

I am looking into it.

@radar

This comment has been minimized.

Show comment
Hide comment
@radar

radar Jun 26, 2012

Member

Do you have some steps that we could use to walk through and see the same issue as you are?

Member

radar commented Jun 26, 2012

Do you have some steps that we could use to walk through and see the same issue as you are?

@radar radar closed this Jun 26, 2012

@radar radar reopened this Jun 26, 2012

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jun 26, 2012

With a fresh installation of Spree (1.1.1 and or 1.2 master) into a Rails application and sample data loaded:

  • Create an order and checkout.
  • Log into the admin console.
  • Locate the order.
  • Capture the payment.
  • Ship the pending shipment.
  • Initiate a RMA for the item.
  • Check the item as received (in the RMA tab)
  • Enter the payment tab and issue a payment to the user for the amount of the RMA adjustment.

At this point, the returns process should complete. However, the order remains locked in "awaiting return" status.

Regard,
Rafael

ghost commented Jun 26, 2012

With a fresh installation of Spree (1.1.1 and or 1.2 master) into a Rails application and sample data loaded:

  • Create an order and checkout.
  • Log into the admin console.
  • Locate the order.
  • Capture the payment.
  • Ship the pending shipment.
  • Initiate a RMA for the item.
  • Check the item as received (in the RMA tab)
  • Enter the payment tab and issue a payment to the user for the amount of the RMA adjustment.

At this point, the returns process should complete. However, the order remains locked in "awaiting return" status.

Regard,
Rafael

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jun 27, 2012

Before, I consider a monkey patch. Has anyone had a chance to peek around at this? I've checked the latest edge with the same results. It appears as if the process return method no longer updates the order. Any guidance would be humbly appreciated

ghost commented Jun 27, 2012

Before, I consider a monkey patch. Has anyone had a chance to peek around at this? I've checked the latest edge with the same results. It appears as if the process return method no longer updates the order. Any guidance would be humbly appreciated

@ghost ghost assigned joneslee85 Aug 23, 2012

@Ben-M

This comment has been minimized.

Show comment
Hide comment
@Ben-M

Ben-M Oct 17, 2012

Contributor

I can confirm that I'm having the same issue. Anyone working on this?

Contributor

Ben-M commented Oct 17, 2012

I can confirm that I'm having the same issue. Anyone working on this?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment