Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

jQuery not included in Admin #2223

Closed
jetsgit opened this Issue · 4 comments

3 participants

@jetsgit

In spree 1-1-stable I am still having this problem.

Fixed locally by advice in issue #1854:

//= require jquery
//= require jquery_ujs
//= require jquery-ui

...added to all.js

jet

@radar
Collaborator

This is because you upgraded your store. Old versions of that branch did not have these requires. We fixed this in that issue that you mentioned but for stores upgrading we don't have a script that will automatically fix this for you.

@radar radar closed this
@andreteves

I created a brand new project (rails 3.2.11) and installed spree as a gem (1.3.1). Apparently jquery is included in the admin/all.js:

//= require jquery
//= require jquery_ujs

//= require admin/spree_core
//= require admin/spree_promo

//= require_tree .

But jquery it is not working in the admin area (it works well in the store). I say that because I cannot access any jquery tags from chrome development console.

Please, any help is very welcome.

@radar
Collaborator
@andreteves

Thanks, problem solved!

But I didn´t understand why is this happening...by using jquery-rails 2.1.4 we are downgrading from jquery 1.9.0 to 1.8.3, right? Was this being caused by a new jquery feature?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.