New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

loosen activemerchant dependency #8081

Merged
merged 1 commit into from Jun 21, 2017

Conversation

Projects
None yet
2 participants
@jGRUBBS
Contributor

jGRUBBS commented Jun 20, 2017

dependency on activemerchant was made too strict in 5b260f3

Since activemerchant does not (rarely) version to the patch level the dependency was essentially locked at 1.66.0

Prior to that commit activemerchant was twiddle-waka'd to the minor version level as is this commit.

I noticed this when trying developing a new gateway integration for activemerchant / spree and I couldn't update activemerchant without updating the spree gemspec.

loosen activemerchant dependency
dependency on activemerchant was made too strict in
5b260f3

Since activemerchant does not (rarely) version to the patch level the
dependency was essentially locked at 1.66.0

Prior to that commit activemerchant was twiddle-waka'd to the minor
version level as is this commit.
@damianlegawiec

This comment has been minimized.

Show comment
Hide comment
@damianlegawiec

damianlegawiec Jun 21, 2017

Member

Thanks @jGRUBBS 👍

Member

damianlegawiec commented Jun 21, 2017

Thanks @jGRUBBS 👍

@damianlegawiec damianlegawiec merged commit 94b2c20 into spree:master Jun 21, 2017

1 of 2 checks passed

ci/circleci Your tests failed on CircleCI
Details
hound No violations found. Woof!
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment