New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

UrlGenerator Bug always has ending slash. #4

Closed
lancepioch opened this Issue Feb 28, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@lancepioch
Copy link

lancepioch commented Feb 28, 2014

Line 71-73 of the UrlGenerator class seems to append an extra slash at the end of generated urls.

There are three default permalink styles for posts: "pretty", "ordinal", and "date". The default of those being "pretty" which ends in /:categories/:year/:month/:day/:title/ a slash. This will work perfectly for this case.

However the problem lies when the permalink style does not end with a "/". One will always be appended. Using "ordinal" or "date" will correctly generate the posts with a .html extension, but however the urls to them (using post.url) will resemble something like "/url/to/post.html/" with an ending slash that invalidates the path.

@yosymfony

This comment has been minimized.

Copy link
Member

yosymfony commented Mar 1, 2014

You are right. Now, the slash at the end depend of permalink style: if permalink style ends with slash then the URL ends with slash.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment