Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Assert compatibility with Guava 26.0-jre+ [DATACASS-599] #768

Closed
spring-projects-issues opened this issue Sep 27, 2018 · 0 comments
Closed

Assert compatibility with Guava 26.0-jre+ [DATACASS-599] #768

spring-projects-issues opened this issue Sep 27, 2018 · 0 comments
Assignees

Comments

@spring-projects-issues
Copy link

@spring-projects-issues spring-projects-issues commented Sep 27, 2018

Kamil Bar opened DATACASS-599 and commented

Guava has removed Futures#transform method without the Executor parameter in version 26.0-jre (after marking it first as deprecated) which makes 2.1.0.RELEASE to fail with NoSuchMethod exception when used with library using Guava 26.0-jre+ i.e.

io.projectreactor:reactor-core:3.2.0.RELEASE

Note that transform version with the Executor parameter is back compatible with Guava 19, so it should be possible to switch to that method version without breaking compatibility. See: https://github.com/google/guava/blob/v19.0/guava/src/com/google/common/util/concurrent/Futures.java#L1276

The offending line is:
https://github.com/spring-projects/spring-data-cassandra/blob/master/spring-data-cassandra/src/main/java/org/springframework/data/cassandra/core/cql/session/DefaultBridgedReactiveSession.java#L159


Affects: 2.1 GA (Lovelace)

Referenced from: pull request #137

Backported to: 2.1.5 (Lovelace SR5), 2.0.14 (Kay SR14)

2 votes, 2 watchers

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.