Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

JavaDoc should be updated to reflect change of requiring an environment. [DATACMNS-530] #999

Closed
spring-projects-issues opened this issue Jul 1, 2014 · 3 comments
Assignees
Labels
type: documentation type: enhancement

Comments

@spring-projects-issues
Copy link

spring-projects-issues commented Jul 1, 2014

Matt Fleshman opened DATACMNS-530 and commented

The JavaDoc (description) on the constructor for the class
org.springframework.data.repository.config.RepositoryConfigurationSourceSupport is incorrect. The description still states it will default to a StandardEnvironment if the given environment parameter is null which is not the case


Affects: 1.8 GA (Dijkstra)

Referenced from: pull request #97

Backported to: 1.9.1 (Evans SR1), 1.8.5 (Dijkstra SR5)

@spring-projects-issues
Copy link
Author

spring-projects-issues commented Jul 1, 2014

Matt Fleshman commented

This is related to DATACMNS-492

@spring-projects-issues
Copy link
Author

spring-projects-issues commented Jul 1, 2014

Oliver Drotbohm commented

Good catch! How did you actually get to that? RepositoryConfigurationSourceSupport isn't necessarily user facing API and thus the internal code change shouldn't cause any issues, should it?

@spring-projects-issues
Copy link
Author

spring-projects-issues commented Oct 6, 2014

Thomas Darimont commented

Please revise

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
type: documentation type: enhancement
Projects
None yet
Development

No branches or pull requests

2 participants