Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for Undertow 1.2 / WildFly 9.0 [SPR-12469] #17075

Closed
spring-issuemaster opened this issue Nov 26, 2014 · 3 comments

Comments

Projects
None yet
2 participants
@spring-issuemaster
Copy link
Collaborator

commented Nov 26, 2014

Juergen Hoeller opened SPR-12469 and commented

WildFly 9.0 will be released with Undertow 1.2, scheduled for (late) Q1 2015. This is interesting for Spring at many levels: deployment on WildFly 9 full profile but also the new WildFly 9 Servlet profile and Undertow standalone.

Undertow 1.2 will ship initial HTTP/2 support, so along with Jetty 9.3, it's also an opportunity for early HTTP/2 support from Spring's side.


Affects: 4.1.2

Issue Links:

  • #16836 Support for Undertow 1.1 / WildFly 8.2
  • #17593 Compatibility with WildFly 9.0 GA
  • #17950 Make UndertowXhrTransport compatible with Undertow 1.3

Referenced from: commits 10d1389

1 votes, 4 watchers

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented May 4, 2015

Juergen Hoeller commented

WildFly 9.0 RC1 is available in the meantime. Good timing for Spring Framework 4.2...

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented May 5, 2015

Brian Clozel commented

Tested the spring-websocket-portfolio with the latest snapshot and Wildfly 9.0.RC1.
websocket support and several other subprotocols were tested.

I'll leave this issue open for now, so as to re-run those tests right before our own RC1 - also if Wildfly has a new RC in the meantime.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented May 9, 2015

Juergen Hoeller commented

Let's mark this as resolved for tracking our status towards 4.2 RC1.

Of course, please do re-run the tests against WildFly 9.0 RC2/GA once available...

Juergen

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.