New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compatibility with WildFly 10 [SPR-13477] #18056

Closed
spring-issuemaster opened this Issue Sep 21, 2015 · 14 comments

Comments

Projects
None yet
2 participants
@spring-issuemaster
Copy link
Collaborator

spring-issuemaster commented Sep 21, 2015

Juergen Hoeller opened SPR-13477 and commented

WildFly 10 is scheduled for general availability in late October now. Let's do comprehensive integration testing for Spring Framework 4.2.3, due in early November.

Note that this issue is separate from #17950 which has been reduced to cover UndertowXhrTransport's version requirement only, not WildFly 10 overall.


Affects: 4.2 GA

Issue Links:

  • #18106 ClassNotFoundException: org.xnio.StreamConnection in Wildfly 10.0.0.CR2 ("depends on")
  • #18197 UndertowRequestUpgradeStrategy not compatible with WildFly anymore ("depends on")
  • #18360 Compatibility with JBoss EAP 7 ("is depended on by")
  • #17950 Make UndertowXhrTransport compatible with Undertow 1.3
  • #18650 Compatibility with Tomcat 8.5.2 and 9.0 M6
  • #19142 Compatibility with WildFly 10.1

0 votes, 5 watchers

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Sep 22, 2015

Brian Clozel commented

All my integration tests are green with the latest wildfly 10.0.0.CR1, with #17950 patch applied.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Sep 29, 2015

Brian Clozel commented

10.0.0.CR2 is out in the meantime.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Sep 29, 2015

Juergen Hoeller commented

With our new Oct 13 target for Spring Framework 4.2.2 (and Boot 1.3's aim to support Undertow 1.3 GA), let's consider this a 4.2.2 issue and simply re-test against the latest WildFly-related artifacts available then, even if it's not technically GA yet. This includes WildFly 10 CR2 but also the upcoming Undertow 1.3 CR3 and Hibernate 5.0.2.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 6, 2015

Brian Clozel commented

All tests are now green with #18106 patch applied.
I'll wait a few days before resolving this issue, in case a new undertow/wildfly RC comes out.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 6, 2015

Juergen Hoeller commented

Good to hear :-)
And indeed, let's wait for Undertow 1.3 RC3 which seems to be just around the corner.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 8, 2015

Brian Clozel commented

Just upgraded to undertow 1.3.0.CR3.
Looking at the commits, I didn't see anything impacting our undertow support.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 8, 2015

Juergen Hoeller commented

Alright, good to know!

WildFly itself apparently aims for a CR3 on Oct 12, just in time for our 4.2.2 release:
https://issues.jboss.org/browse/wfly/?selectedTab=com.atlassian.jira.jira-projects-plugin:roadmap-panel

Juergen

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 12, 2015

Stéphane Nicoll commented

Trying out undertow 1.3.0.Final as we would like to upgrade in Boot as well.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 12, 2015

Brian Clozel commented

Nice, let me run my tests and I'll let you know!

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 12, 2015

Brian Clozel commented

Never mind, Stéphane Nicoll already ran the full test suite.
Also, the latest changes do not affect our support.

There should be a Wildfly 10.0.0.CR3 release today, so I'll leave this issue open for now.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 14, 2015

Juergen Hoeller commented

Let's mark this as resolved for the time being, since WildFly 10 CR3 seems to be delayed.
There's no reason to assume that anything will break after Undertow 1.3 GA, after all.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 19, 2015

Juergen Hoeller commented

Reopening this one since WildFly 10 CR3 still isn't out, with WildFly 10 GA now probably being very close to our Spring Framework 4.2.3 target in early November: another opportunity for integration testing at that point.

Juergen

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 20, 2015

Juergen Hoeller commented

WildFly 10 CR3 eventually went out late yesterday, but now there's a CR4 coming up in late October... in any case, worth re-testing ahead of our 4.2.3 release.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

spring-issuemaster commented Oct 29, 2015

Brian Clozel commented

All my tests are green on Wildfly CR4, so this version + #18197 fixes work for me!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment