Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Require Undertow 1.3.5+, Tyrus 1.11+, Jetty 9.3+, Tomcat 8.5+ [SPR-13495] #18073

Closed
spring-issuemaster opened this issue Sep 24, 2015 · 0 comments
Assignees
Labels
Milestone

Comments

@spring-issuemaster
Copy link
Collaborator

@spring-issuemaster spring-issuemaster commented Sep 24, 2015

Juergen Hoeller opened SPR-13495 and commented

Undertow, Tyrus, Jetty and even Tomcat all caused some breaking changes recently which we're currently working around through reflection and mock compilation. As of Spring Framework 5, we should bump up the minimum requirements to mid-2015 versions of those... as featured in WildFly 10, GlassFish 4.1.1, WebLogic 12.2.1 in the case of Undertow and Tyrus. This implies that Spring 5's WebSocket support won't work on WildFly 8/9, GlassFish 4.1.0 and WebLogic 12.1.3 anymore which should be acceptable in 2017.


Issue Links:

  • #17731 Support for Jetty 9.3 ("depends on")
  • #17802 TomcatInstrumentableClassLoader should support Tomcat 7.0.63+ as well ("depends on")
  • #17825 Compatibility with WebLogic 12.2.1 / Tyrus 1.11 ("depends on")
  • #18142 Compatibility with GlassFish 4.1.1 / Tyrus 1.12 ("depends on")
  • #18171 Make use of native doUpgrade operation in Undertow 1.3.5+ / 1.4 ("depends on")
  • #18694 Initial compatibility with Undertow 2.0
  • #19604 Revisit dependency baseline: Jetty 9.4+, OkHttp 3+

Referenced from: commits fb5a096, 770f0c0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.