Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade to Objenesis 2.5 [SPR-15146] #19712

Closed
spring-issuemaster opened this issue Jan 16, 2017 · 1 comment

Comments

@spring-issuemaster
Copy link
Collaborator

commented Jan 16, 2017

Juergen Hoeller opened SPR-15146 and commented

Objenesis 2.5 is out, including support for JDK 9 build 151+.


Issue Links:

  • #17819 Upgrade to Objenesis 2.2
  • #18609 Upgrade to ASM 5.1
  • #18864 Upgrade to Objenesis 2.4
  • #19637 Upgrade to ASM 5.2
  • #19713 Upgrade to CGLIB 3.2.5
  • #20227 Jdep issue on org.springframework.objenesis.instantiator.sun.UnsafeFactoryInstantiator
  • #20159 Upgrade to Objenesis 2.6 for Google App Engine Standard on Java 8 and for better JDK 9 support

Referenced from: commits 4af6d58, 74596a6, 5555414, 53e2d7d

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented Jan 22, 2017

Juergen Hoeller commented

There's an Objenesis 2.5.1 patch release in the meantime which we should be using instead.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.