Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compatibility with Groovy 2.5 [SPR-15407] #19970

Closed
spring-projects-issues opened this issue Apr 3, 2017 · 2 comments
Closed

Compatibility with Groovy 2.5 [SPR-15407] #19970

spring-projects-issues opened this issue Apr 3, 2017 · 2 comments
Assignees
Milestone

Comments

@spring-projects-issues
Copy link
Collaborator

@spring-projects-issues spring-projects-issues commented Apr 3, 2017

Juergen Hoeller opened SPR-15407 and commented

Groovy 2.5 alpha 1 is out now... might enter the beta stage in time for our 5.0 GA.


Issue Links:

  • #17177 Compatibility with Groovy 2.4

Referenced from: commits 0092653, ce002b4, b3b233b, 018cc45

@spring-projects-issues
Copy link
Collaborator Author

@spring-projects-issues spring-projects-issues commented Jun 16, 2017

Juergen Hoeller commented

Groovy 2.5 is at beta 1 now, so worth upgrading our Spring Framework 5.0 build to.

Like with JUnit 5, this remains early support until they release their finals.

@spring-projects-issues
Copy link
Collaborator Author

@spring-projects-issues spring-projects-issues commented May 14, 2018

Juergen Hoeller commented

Groovy 2.5 finally reached its release candidate stage, so let's upgrade our build to it for Spring Framework 5.1 (after having had to downgrade it again for Spring Framework 5.0 GA last year).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants