Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade to JUnit Jupiter 5.0 M6 [SPR-15791] #20346

Closed
spring-issuemaster opened this issue Jul 18, 2017 · 4 comments

Comments

Projects
None yet
2 participants
@spring-issuemaster
Copy link
Collaborator

commented Jul 18, 2017

Sam Brannen opened SPR-15791 and commented

JUnit Jupiter 5.0 M6 is already available in Maven Central: https://repo1.maven.org/maven2/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/


Affects: 5.0 RC2

Issue Links:

  • #20284 Upgrade to JUnit Jupiter 5.0 M5
  • #20293 Upgrade to JUnit 5.0 GA

Referenced from: commits 1e66191

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented Jul 18, 2017

Sam Brannen commented

Waiting for M6 artifacts to show up on repo.spring.io:

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':spring-test:compileKotlin'.
> Could not resolve all dependencies for configuration ':spring-test:optional'.
   > Could not find org.junit.jupiter:junit-jupiter-api:5.0.0-M6.
     Searched in the following locations:
         https://repo.spring.io/libs-release/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/junit-jupiter-api-5.0.0-M6.pom
         https://repo.spring.io/libs-release/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/junit-jupiter-api-5.0.0-M6.jar
         https://repo.spring.io/milestone/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/junit-jupiter-api-5.0.0-M6.pom
         https://repo.spring.io/milestone/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/junit-jupiter-api-5.0.0-M6.jar
         https://repo.spring.io/snapshot/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/junit-jupiter-api-5.0.0-M6.pom
         https://repo.spring.io/snapshot/org/junit/jupiter/junit-jupiter-api/5.0.0-M6/junit-jupiter-api-5.0.0-M6.jar
     Required by:
         project :spring-test
@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented Jul 18, 2017

Sam Brannen commented

Now experiencing an error with the build:

/Users/XXX/.gradle/caches/modules-2/files-2.1/org.junit.jupiter/junit-jupiter-api/5.0.0-M6/d5845b87787a935ae41cef4f738ee1b0f948d864/junit-jupiter-api-5.0.0-M6.jar(org/junit/jupiter/api/extension/ConditionEvaluationResult.class): warning: Cannot find annotation method 'value()' in type 'API': class file for org.junit.platform.commons.meta.API not found
warning: unknown enum constant Usage.Experimental
  reason: class file for org.junit.platform.commons.meta.API$Usage not found

Investigating...

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented Jul 18, 2017

Sam Brannen commented

Was just an issue with the local Gradle cache.

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented Jul 18, 2017

Sam Brannen commented

Upgrade performed in the following commit: 1e66191

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.