Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

spring-aspects should remain on AspectJ 1.8.9 by default (since aspectjrt 1.8.10 requires Java 7+) [SPR-15836] #20391

Closed
spring-issuemaster opened this Issue Jul 31, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@spring-issuemaster
Copy link
Collaborator

commented Jul 31, 2017

Sören Chittka opened SPR-15836 and commented

Since Version 4.3.10.RELEASE spring-aspects depends on aspectjrt 1.8.10, which is compiled against Java 7 (according to Maven).

This makes Spring Framework incompatible with Java 6.


Affects: 4.3.10

Issue Links:

  • #20525 Upgrade to AspectJ 1.9 beta 7

Referenced from: commits fa2c377

@spring-issuemaster

This comment has been minimized.

Copy link
Collaborator Author

commented Jul 31, 2017

Juergen Hoeller commented

Indeed, I missed that when upgrading the default dependency declaration there... and I forgot that spring-aspects has a required dependency on AspectJ where it's not the application POM specifying the actual AspectJ version for a given project.

So I guess we need to downgrade the declaration to AspectJ 1.8.9 for Spring Framework 4.3.11 which is not a big deal. For the time being, you can simply downgrade it yourself in your POM; spring-aspects is still binary-compatible with 1.8.9 after all.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.