Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade to AspectJ 1.9 beta 7 [SPR-15974] #20525

Closed
spring-projects-issues opened this issue Sep 18, 2017 · 2 comments
Closed

Upgrade to AspectJ 1.9 beta 7 [SPR-15974] #20525

spring-projects-issues opened this issue Sep 18, 2017 · 2 comments
Assignees
Labels
in: core type: task
Milestone

Comments

@spring-projects-issues
Copy link
Collaborator

@spring-projects-issues spring-projects-issues commented Sep 18, 2017

Juergen Hoeller opened SPR-15974 and commented

We're currently building against AspectJ 1.9 beta 6 for JDK 9 compatibility in our test suite. It'd be great to get out of beta there for our 5.0 GA release.

If AspectJ 1.9 remains in pre-release stage for some further time, we'll have to separate the version that we're exposing in the spring-aspects POM (downgraded to 1.8.10) from the one that we use in our framework build (latest 1.9 milestone), eventually catching up once AspectJ 1.9 goes GA.


Affects: 5.0 RC4

Issue Links:

  • #19586 Pointcut evaluation fails against AbstractHandlerMethodMapping$MappingRegistry with AspectJ 1.8.10
  • #20391 spring-aspects should remain on AspectJ 1.8.9 by default (since aspectjrt 1.8.10 requires Java 7+)
  • #18941 Compatibility with JDK 9 GA
  • #18412 Upgrade to AspectJ 1.9 beta 3 (for build compatibility with JDK 9 build 95+)
  • #15898 Spring 4.0.0.RELEASE depends on aspectjweaver 1.8.0.M1 not found in Maven Central
  • #20626 Upgrade to AspectJ 1.9 RC1
@spring-projects-issues
Copy link
Collaborator Author

@spring-projects-issues spring-projects-issues commented Sep 25, 2017

Juergen Hoeller commented

AspectJ 1.9 beta 7 is available now, so we're going to use this one for ajc in spring-aspects (where we actually need a special JDK compatible version) and for running the spring-aop tests (since several tests otherwise won't pass)... while exposing AspectJ 1.8.10 as a runtime dependency in our Maven POMs (which is known to work on JDK 9 as well for common purposes, and can be individually upgraded to 1.9 in user POMs if necessary).

@spring-projects-issues
Copy link
Collaborator Author

@spring-projects-issues spring-projects-issues commented Sep 26, 2017

Juergen Hoeller commented

We're exposing AspectJ 1.8.11 now, also for the spring-aop and spring-context tests where it's known to work fine on JDK 9 for our purposes. So AspectJ 1.9 beta 7 is only used for ajc in spring-aspects now, as originally intended.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
in: core type: task
Projects
None yet
Development

No branches or pull requests

2 participants