Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Build against EE 8 API level wherever possible [SPR-15996] #20545

Closed
spring-projects-issues opened this issue Sep 24, 2017 · 0 comments
Closed

Build against EE 8 API level wherever possible [SPR-15996] #20545

spring-projects-issues opened this issue Sep 24, 2017 · 0 comments
Assignees
Labels
type: task
Milestone

Comments

@spring-projects-issues
Copy link
Collaborator

@spring-projects-issues spring-projects-issues commented Sep 24, 2017

Juergen Hoeller opened SPR-15996 and commented

While we're building against several final EE 8 APIs in 5.0 RC4 already - Servlet 4.0 (#20434), JPA 2.2 (#20425), Bean Validation 2.0 (#20363), JSON Binding 1.0 (#20149) -, a few of them are still left: namely JAXB 2.3, JAX-WS 2.3, and also the latest maintenance versions of Common Annotations (1.3.1) and the Interceptor API (1.2.1). Let's close that gap for 5.0 GA.


Affects: 5.0 RC4

Issue Links:

  • #20149 Use Apache Johnzon 1.1 for JSON-B integration tests ("depends on")
  • #20363 Compatibility with Hibernate Validator 6.0 GA ("depends on")
  • #20425 Compatibility with EclipseLink 2.7 ("depends on")
  • #20434 Upgrade to Servlet API 4.0 for MVC (PushBuilder and Servlet mocks) ("depends on")
  • #18941 Compatibility with JDK 9 GA

Referenced from: commits 65f556c

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
type: task
Projects
None yet
Development

No branches or pull requests

2 participants