SEC-1035: Update build to use Spring 3 #1286

Closed
spring-issuemaster opened this Issue Nov 13, 2008 · 3 comments

1 participant

@spring-issuemaster

Luke Taylor said:

The new build needs to be Spring 2.5 compatible but should normally run against Spring 3 for EL support. The current copy of the EL code in the security svn should also be removed once the Spring version is added. Builds are here

http://s3browse.com/explore/repository.springsource.com/maven/bundles/snapshot/org/springframework/

@spring-issuemaster

Luke Taylor said:

I’ve added the org.springframework.expression dependency to the build, but there will be some problems with transitive dependencies etc so the remaining Spring dependencies are still at 2.5. As long as Spring-EL remains independent of Spring 3.0-specific code, this should be OK.

@spring-issuemaster

Luke Taylor said:

The build is now using Spring 3.0.0.M1, in preparation for our milestone release.

@spring-issuemaster spring-issuemaster added this to the 3.0.0 M1 milestone Feb 5, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment