SEC-1134: Spring Security pom depends on spring-support which latest version is 2.0.8 #1383

spring-issuemaster opened this Issue Apr 3, 2009 · 2 comments


None yet

1 participant


Keith Donald (Migrated from SEC-1134) said:

I thought Spring security aligned with Spring 2.5, if so it should depend on 2.5.6 spring-context-support, not the old spring-support. This results in having to do excludes for most folks on Spring 2.5.

org.springframework spring-support runtime

Luke Taylor said:

Hi Keith,

Spring Security 2.0.x is built against Spring 2.0.×. The Spring Framework version is controlled by the spring.version property in the parent maven pom file. The faq also has this info:

The current trunk is building against Spring 3.


Luke Taylor said:

Closing. For reference, the next release will require Spring 3.0 and JDK 1.5 as a minimum.

@spring-issuemaster spring-issuemaster added this to the 3.0.0 M1 milestone Feb 5, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment