SEC-1647: parent pom has incorrect version number for spring #1888

spring-issuemaster opened this Issue Dec 28, 2010 · 2 comments

1 participant


Quinton McCombs (Migrated from SEC-1647) said:

spring-security-parent-3.0.5.RELEASE.pom is including 3.0.3.RELEASE dependencies instead of 3.0.5.RELEASE.

Line # 618: 3.0.3.RELEASE


Luke Taylor said:

This isn't really a bug. 3.0.3 is the version it was built against and is the minimum recommended version.


Stefan Gheorghiu said:

If these artifacts are used for build only, why didn't you explicitly specify scope 'compile'? Now, by simply including one of the spring-security artifacts, I have half of my core spring artifacts of version 3.0.3 and another half og 3.0.5. In order to fix it, I have the only way out — to override versions of every single artifact that you use in spring-security-parent in my dependencyManagement section. So stupid...

@spring-issuemaster spring-issuemaster added this to the 3.0.6 milestone Feb 5, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment