SEC-2350: Warning when using 3.2.0.RC2 with Spring Framework 4.0 #2576

Closed
spring-issuemaster opened this Issue Oct 4, 2013 · 0 comments

Comments

Projects
None yet
2 participants
@spring-issuemaster

Nick Williams (Migrated from SEC-2350) said:

When starting an application running Spring Framework 4.0 and Spring Security 3.2.0.RC2, the following message is logged:

12:19:08.129 [localhost-startStop-1] WARN org.springframework.security.core.SpringSecurityCoreVersion org.springframework.security.core.SpringSecurityCoreVersion.performVersionChecks(SpringSecurityCoreVersion.java:53): *** Spring Major version '3' expected, but you are running with version: 4.0.0.BUILD-SNAPSHOT. Please check your classpath for unwanted jar files.

Spring Security should certainly warn if Spring Framework is older than supported, but it should not warn if Spring Framework is newer that expected. At the very least, 3.2.0 should support Spring Framework 4.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment