SEC-2407: Better error message for missing securityFilterChainBuilders #2627

Closed
spring-issuemaster opened this Issue Nov 20, 2013 · 0 comments

Comments

Projects
None yet
2 participants
@spring-issuemaster

Dave Syer (Migrated from SEC-2407) said:

The error message below does not really provide any value and should be improved

Caused by: java.lang.IllegalStateException: At least one SecurityFilterBuilder needs to be specified. Invoke FilterChainProxyBuilder.securityFilterChains
    at org.springframework.util.Assert.state(Assert.java:385)
    at org.springframework.security.config.annotation.web.builders.WebSecurity.performBuild(WebSecurity.java:283)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment