Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

webServiceTemplate.marshalSendAndReceive() is cleaning up the xmlns attribute [SWS-982] #1053

Open
gregturn opened this issue Mar 17, 2017 · 0 comments

Comments

@gregturn
Copy link
Member

@gregturn gregturn commented Mar 17, 2017

Bilguun Bayarmagnai opened SWS-982 and commented

I'm using xstream and setting "xmlns" attribute using @XStreamAsAttribute. It works as expected when using XStreamMarshaller#marshal(...) method. However when using webServiceTemplate.marshalSendAndReceive(...) method the xmlns attributes gets cleared out and results in empty string like: (I found out this with tracing)

<generate xmlns="" ...

Because the xml namespace changes depending on the envoirnment (dev & prod), and it seems like there's no easy way to achieve that with default jaxb marshaller. With Xstream, setting it on the attribute seems like an easier hack.

Please help me with this, thanks.


Affects: 2.4.0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.