Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2.4.1 uses a new minor version of WSS4J [SWS-1001] #1071

Closed
gregturn opened this issue Oct 24, 2017 · 1 comment
Closed

2.4.1 uses a new minor version of WSS4J [SWS-1001] #1071

gregturn opened this issue Oct 24, 2017 · 1 comment
Assignees
Labels
Milestone

Comments

@gregturn
Copy link
Member

@gregturn gregturn commented Oct 24, 2017

Andy Wilkinson opened SWS-1001 and commented

2.4.0.RELEASE used WSS4J 2.1.4, but 2.4.1 has jumped to 2.2. Generally speaking, a minor upgrade to a dependency in a maintenance release should be avoided. IMO, 2.4.2 should revert to 2.1.x.


Affects: 2.4.1

Referenced from: commits eaa5bba

@gregturn
Copy link
Member Author

@gregturn gregturn commented Oct 24, 2017

Greg Turnquist commented

Rolled back 2.x branch's wss4j2 to 2.1.11, the latest version of the 2.1 branch.

@gregturn gregturn closed this Oct 24, 2017
@gregturn gregturn added the type: bug label Sep 22, 2020
@gregturn gregturn added this to the 2.4.2 milestone Sep 22, 2020
@gregturn gregturn self-assigned this Sep 22, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.