Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OSGi import of org.springframework.security.authentication seems to be the wrong version [SWS-705] #800

Closed
gregturn opened this issue Apr 28, 2011 · 3 comments
Assignees
Labels
Milestone

Comments

@gregturn
Copy link
Member

@gregturn gregturn commented Apr 28, 2011

Aaron Sutula opened SWS-705 and commented

I'm using an OSGi bundle from the Springsource Enterprise Bundle Repository, org.springframework.ws.soap.security_2.0.0.RELEASE . This bundle imports the package org.springframework.security.authentication at version="[2.0.0,3.0.0)" (to clarify, this means greater than or equal to 2.0.0 and less than 3.0.0). This same import information still seems to be in the Spring WS trunk. The org.springframework.security.authentication package is provided by Spring Security Core, but that package doesn't seem to exist in versions of Spring Securtiy Core prior to 3.0.0. This is causing org.springframework.ws.soap.security to be unable to resolve its dependency on Spring Security Core.


Affects: 2.0 GA

Reference URL: http://forum.springframework.org/showthread.php?t=108577

Referenced from: commits 6b27590

@gregturn
Copy link
Member Author

@gregturn gregturn commented Apr 28, 2011

Aaron Sutula commented

Looking at this more, I see the Spring WS parent pom specifies use of Spring Security Core 3.0.2. So the issue seems to be that the template.mf file for the Spring WS security module was not updated to reflect that: https://fisheye.springsource.org/browse/spring-ws/trunk/security/template.mf?hb=true. It still constrains use of Spring Security Core from [2.0.0-3.0.0).

@gregturn
Copy link
Member Author

@gregturn gregturn commented May 19, 2011

Arjen Poutsma commented

This is now fixed: I changed the OSGi range to [3.0.0, 4.0.0)

@gregturn
Copy link
Member Author

@gregturn gregturn commented May 4, 2012

Arjen Poutsma commented

Closing old issues

@gregturn gregturn closed this May 4, 2012
@gregturn gregturn added the type: bug label Sep 22, 2020
@gregturn gregturn added this to the 2.0.2 milestone Sep 22, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.