Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wss4jSecurityInterceptor in spring-ws-security version 2.2.0 is not compatible with wss4j version 2.0.3 [SWS-916] #991

Open
gregturn opened this issue Sep 16, 2015 · 1 comment

Comments

@gregturn
Copy link
Member

@gregturn gregturn commented Sep 16, 2015

Himaa Kishore D opened SWS-916 and commented

Wss4jSecurityInterceptor in spring-ws-security version 2.2.0.RELEASE is not compatible with wss4j version 2.0.3 which undergone package restructure.

org.apache.ws.security.WSSecurityException is a java class in lower versions of wss4j jar and currently it is restructured to org.apache.wss4j.common.ext.WSSecurityException in wss4j version 2.0.3.

So i'm getting class not found exception for org.apache.ws.security.WSSecurityException class when calling Wss4jSecurityInterceptor .


Affects: 2.2.0.RELEASE

1 votes, 3 watchers

@gregturn
Copy link
Member Author

@gregturn gregturn commented Sep 17, 2015

Greg Turnquist commented

Spring WS is built against Wss4j 1.6.15. Moving to Wss4j 2.0.5 is a major breaking change.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

1 participant