Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wrong error markers in properties files #314

Closed
slavap opened this issue Jun 27, 2019 · 6 comments

Comments

@slavap
Copy link

commented Jun 27, 2019

If value has \ then "Missing LineBreak" error is wrongly shown.
Example:
btnNewEntity=New \n Entity

@martinlippert

This comment has been minimized.

Copy link
Member

commented Jul 4, 2019

@kdvolder can you take a look at this?

@kdvolder

This comment has been minimized.

Copy link
Member

commented Jul 5, 2019

I've actually seen it too while working on some Eclipse code... the error showed up in a "plugin.properties" file somehow. I haven't debugged this problem and not yet sure where it might be coming from. But the fact that it showed up in 'plugin.properties' file probably means its not actually an STS but an Eclipse platform issue. I'll try debugging it now.

@kdvolder

This comment has been minimized.

Copy link
Member

commented Jul 5, 2019

Error also shows up 'application.properties' file in boot project in STS 4. When I open this same file / project in Vanilla Eclipse it doesn't show an error in the file. Still not sure what is producing this error, I suspect it may be the generic editor together with text mate grammar for properties files. Maybe a 'bug' in the textmate grammar.

@kdvolder

This comment has been minimized.

Copy link
Member

commented Jul 5, 2019

Had a bit of trouble getting setup for debugging, but finally... I was able to confirm that actually the error does originate inside our language server.

@spring-issuemaster spring-issuemaster added finished and removed started labels Jul 5, 2019

@martinlippert martinlippert added this to the 4.3.1.RELEASE milestone Jul 8, 2019

@spring-issuemaster

This comment has been minimized.

Copy link

commented Jul 8, 2019

(comment in Pivotal Tracker added by Kris De Volder:)

Wanted to verify the fix in a recent snapshot / nightly build, but for some reason they haven't run since this fix was pushed last week. I've kicked a few builds to try and see if they'll go through this time.

@spring-issuemaster

This comment has been minimized.

Copy link

commented Jul 12, 2019

(comment in Pivotal Tracker added by Nieraj Singh:)

Verified in 4.3.1 Release. I no longer get a missing LineBreak at 'n' error when I add something like:

btnNewEntity=New \n Entity

to application.properties

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.