Permalink
Browse files

Update dependencies

  • Loading branch information...
blink1073 committed Mar 12, 2016
1 parent eb42917 commit 3f4b5121f99f6aec1e70dba4151e07ea311cda27
Showing with 8 additions and 5 deletions.
  1. +5 −4 README.md
  2. +1 −0 conda.recipe/meta.yaml
  3. +2 −1 setup.py
@@ -139,17 +139,18 @@ a Python version greater than 2.7 (Python 3.2 is not supported anymore).
* **Python** 2.7 or 3.3+
* **PyQt5** 5.2+ or **PyQt4** 4.6+: PyQt5 is recommended.
* **qtconsole**: Enhanced Python interpreter.
* **Rope** and **Jedi**: Editor code completion, calltips
* **Rope** and **Jedi**: Editor code completion, calltips.
and go-to-definition.
* **Pyflakes**: Real-time code analysis.
* **Sphinx**: Rich text mode for the Help pane
* **Sphinx**: Rich text mode for the Help pane.
* **Pygments**: Syntax highlighting for all file types it supports.
* **Pylint**: Static code analysis.
* **Pep8**: Style analysis.
* **Psutil**: CPU and memory usage on the status bar.
* **Nbconvert**: Manipulation of notebooks in the Editor.
* **Qtawesome**: To have an icon theme based on FontAwesome
* **Pickleshare**: Show import completions on the Python consoles
* **Qtawesome**: To have an icon theme based on FontAwesome.
* **Pickleshare**: Show import completions on the Python consoles.
* **PyZMQ**: Run introspection services asynchronously.

### Optional dependencies

@@ -27,6 +27,7 @@ requirements:
- psutil
- pylint
- qtawesome
- pyzmq
- python.app [osx]

about:
@@ -272,7 +272,8 @@ def run(self):
'pylint',
'psutil',
'qtawesome',
'pickleshare'
'pickleshare',
'pyzmq'
]

if 'setuptools' in sys.modules:

0 comments on commit 3f4b512

Please sign in to comment.