Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[warn] kq_init: detected broken kqueue #3730

Closed
lxkain opened this issue Nov 23, 2016 · 15 comments

Comments

@lxkain
Copy link

commented Nov 23, 2016

Description of your problem

What steps will reproduce the problem?

  1. Start 3.0.2 on OSX from the terminal

What is the expected output? What do you see instead?
Expected silent startup. Instead I see:
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0

Please provide any additional information below
Obviously this is a very minor issue, and I'm only reporting it here in case it points to another more serious problem. Thank you for a great project!

Versions and main components

  • Spyder Version:
  • Python Version:
  • Operating system:

Dependencies

Please go to the menu entry Help > Optional Dependencies (or
Help > Dependencies), press the button Copy to clipboard
and paste the contents below:

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Nov 23, 2016

Could you run in a terminal

export EVENT_NOKQUEUE=1

and try again?

@lxkain

This comment has been minimized.

Copy link
Author

commented Nov 23, 2016

That fixes it, yes.

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Nov 23, 2016

I took that from here: tmux/tmux#475 (comment)

It seems you need to update libevent to fix those errors :-)

@ccordoba12 ccordoba12 closed this Nov 23, 2016

@lxkain

This comment has been minimized.

Copy link
Author

commented Nov 23, 2016

OK, seems like it's harmless, thanks for the background.

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Nov 23, 2016

No prob :-)

ngs added a commit to ngs/dotfiles that referenced this issue Jan 16, 2017
@CoderCoderCoder

This comment has been minimized.

Copy link

commented Jul 19, 2017

Fixed by "brew reinstall libevent"

@themanutdmaniac

This comment has been minimized.

Copy link

commented Aug 17, 2017

@ccordoba12
the same issue crops up even though i followed all your steps...:(

@themanutdmaniac

This comment has been minimized.

Copy link

commented Aug 17, 2017

[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0

@petersgiles

This comment has been minimized.

Copy link

commented Aug 23, 2017

@goanpeca closed my issue referring me here
see (ContinuumIO/anaconda-issues#4535) for my System information


@themanutdmaniac I am having the same experience.

I typed this in the terminal and it didn't change anything

export EVENT_NOKQUEUE=1

also did these based on reading other related issues

brew update
brew reinstall libevent
brew install --HEAD tmux

but no change

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Aug 23, 2017

@amendelo

This comment has been minimized.

Copy link

commented Sep 23, 2017

This command "export EVENT_NOKQUEUE=1" did not work on my computer.

I fixed this issue on my computer by uninstalling and reinstalling anaconda.

@Neven47

This comment has been minimized.

Copy link

commented Sep 24, 2017

Thank you, it fixed it.

@ghltshubh

This comment has been minimized.

Copy link

commented Nov 11, 2017

Though harmless it is still irritating. And I am getting
Failed to compute left/right minimum bearings for "GB18030 Bitmap"
along with it afterwards. Can't find it's permanent solution.

@x-R4y

This comment has been minimized.

Copy link

commented Nov 19, 2017

export EVENT_NOKQUEUE=1 did not work for me either.
Neither did libevent reinstallation, update or anaconda reinstallation..
is there anything left to try?
Also, does the error cause any substantial malfunction or can it be disregarded?

@mabovo

This comment has been minimized.

Copy link

commented Dec 21, 2017

Thank you, it fixed it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
10 participants
You can’t perform that action at this time.