Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

spyder 3.3.3 icon theme Spyder 3 problem with PyQt 5.12 #8748

Closed
danieltomasz opened this issue Feb 11, 2019 · 18 comments

Comments

Projects
None yet
7 participants
@danieltomasz
Copy link

commented Feb 11, 2019

Problem Description

After updating to Spyder 3.3.3 (on Linux, with Python 3.6.7 64-bit | | Qt 5.12.1 | PyQt5 5.12 ) spyder icon theme "Spyder 3" stopped working (because of coming with this version PyQt upgrade probably) . Only the "Spyder 2" icon theme is working.
Below the look of Spyder3 icon theme
screenshot from 2019-02-11 10-36-08

After reverting to PyQt 5.9.2 the icon set Spyder3 is working again.

@ccordoba12 ccordoba12 added this to the v3.3.4 milestone Feb 11, 2019

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Feb 11, 2019

Yeah, we noticed that too but we don't know what could be causing this. I think it's a problem with PyQt5 because QtAwesome (the library we use to display our Spyder 3 icon theme) is working fine with PySide2 5.12.

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Feb 11, 2019

For now please downgrade PyQt5 to its 5.11 version with

pip install pyqt5==5.11.*

@hiccup7 hiccup7 referenced this issue Feb 11, 2019

Closed

release 2019-01 follow-up #687

11 of 11 tasks complete
@stonebig

This comment has been minimized.

Copy link
Contributor

commented Feb 11, 2019

I confirm @hiccup7 remark, that Spyder2 theme of icons is working, to the opposite of Spyder3 theme
image

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Feb 12, 2019

That's right, the spyder2 icon theme works ok.

@Gra55h0pper

This comment has been minimized.

Copy link

commented Feb 12, 2019

Posting here as it seems to be related and may help. I was facing an issue on Windows-10 where after upgrading to Spyder3.3.3 it wouldn't start anymore. Calling spyder3.exe would simply return with the PowerShell prompt without anything else happening.

Downgrading to pyqt5 5.11 as per above fixed the issue.

@jcafhe

This comment has been minimized.

Copy link

commented Feb 14, 2019

Posting here as it seems to be related and may help [...] Downgrading to pyqt5 5.11 as per above fixed the issue.

@Gra55h0pper I've just had the same issue and I think this is related to the missing PyQtWebEngine package which was part of PyQt5 until 5.12.
On linux, I've got a nice error in QtPy ModuleNotFoundError: No module named 'PyQt5.QtWebKitWidgets' but on win7, it silently returns to shell. So basically you have to pip install PyQtWebEngine (or conda).

@danieltomasz

This comment has been minimized.

Copy link
Author

commented Feb 14, 2019

Unfortunately installing it is not helping, the problem with missing icons stays.
I got ModuleNotFoundError: No module named 'PyQt5.QtWebKitWidgets' when Spyder fails to starts, which disappear after uninstalling and installing again the aforementioned package but there is still Spyder3 icon set problem.

@jcafhe

This comment has been minimized.

Copy link

commented Feb 14, 2019

Yes, you are right, sorry for my misleading comment, I was telling to Gra55hOpper that his issue may be not related to the icon problem.
In fact, after installing the missing package, I ran into the icon problem too. This is how I've came to this particular issue and to the Gra55hOpper's comment.

@stonebig

This comment has been minimized.

Copy link
Contributor

commented Feb 14, 2019

@ccordoba12 is there any problem if using PyQt5-5.12 with the Spyder2 theme ?

@stonebig

This comment has been minimized.

Copy link
Contributor

commented Feb 14, 2019

there is a PyQt5-5.12-5.12.1_a wheel today, adding libQt5QuickShapes.so.5 that was missing in PyQt 5.12.

@Gra55h0pper

This comment has been minimized.

Copy link

commented Feb 15, 2019

@jcafhe, TNX! Indeed pip install PyQtWebEngine fixed the startup problem I was facing.
And it's indeed not a solution for the Spyder3 icon theme problem in this thread as I'm facing the same thing myself now.

@stonebig

This comment has been minimized.

Copy link
Contributor

commented Feb 17, 2019

moving to Spyder 2 icon them is a 5 second switch: Tools->Preferences->General, then see Icon Theme dropdown box

image

@stonebig

This comment has been minimized.

Copy link
Contributor

commented Feb 17, 2019

is the icon issue related to this ? https://bugreports.qt.io/browse/QTBUG-68853

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Feb 17, 2019

@stonebig, this is a bug in PyQt, please read my #8748 (comment) above:

QtAwesome (the library we use to display our Spyder 3 icon theme) is working fine with PySide2 5.12.

@hiccup7

This comment has been minimized.

Copy link

commented Feb 17, 2019

Spyder v3.3.4 has already fixed a number of important issues with v3.3.3. I don't want to see this issue block a quick release of v3.3.4. Here are my suggestions to resolve this issue:

  1. Define the problem as an incompatibility between QtAwesome and PyQt 5.12. Thus, the problem is not a problem with Spyder, but instead a problem between two upstream packages.
  2. To provide a good Spyder experience for inexperienced Python users, maximize Spyder's compatibility with a variety of upstream packages. Specifically, make the Spyder 2 icon theme the default on the first run of Spyder.
  3. Change the preference labels of the icon themes: Spyder 2 -> Standard, Spyder 3 -> QtAwesome. This helps users to understand the Spyder 2 icon theme is not deprecated and to consider QtAwesome issues if the Spyder 3 icon theme fails.
  4. Create a new issue for the incompatibility at https://github.com/spyder-ide/qtawesome List it in the known Spyder issues so as to avoid duplicates by Spyder users. Invite Riverbank Computing Limited to discuss the best way to resolve the incompatibility. The resolution may be after the Spyder v3.3.4 release, so Spyder users need only update the upstream package when available.
@ccordoba12

This comment has been minimized.

Copy link
Member

commented Mar 3, 2019

Pinging @mingwandroid about this problem since you said you're about to update the Qt/PyQt conda packages to 5.12.

Ray, it seems this is a problem with PyQt5 only because QtAwesome (the library behind our icons) is working fine with PySide2. We reported this problem upstream but haven't received an answer so far.

@ccordoba12

This comment has been minimized.

Copy link
Member

commented Mar 5, 2019

@xu-kai-xu, that's a different issue from this one. Please don't post anymore here and open a new issue instead.

@SurajMeena

This comment has been minimized.

Copy link

commented Jun 22, 2019

I solved similar issue by installing qt bindings from conda web page, https://anaconda.org/anaconda/pyqt. I don't know it will work for you or not, but it's worth a shot.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.