Skip to content

Can't up php install problem #46

Open
Freyskeyd opened this Issue Mar 25, 2014 · 11 comments

5 participants

@Freyskeyd

Hey,

I'm trying to use this repo to make a vagrant setup but i get a very long vagrant up and it still not working (error throw)

Notice: /Stage[main]/Php::Dev/Package[php5-dev]/ensure: ensure changed 'purged' to 'present'
Notice: /Stage[main]/Php::Pear/Exec[php::pear::auto_discover]/returns: executed successfully
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[xdebug]/Package[pecl.php.net/xdebug]/ensure: created
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[jsmin]/Package[pecl.php.net/jsmin-beta]/ensure: created
Notice: /Stage[main]/Php::Extension::Curl/Php::Extension[curl]/Package[php5-curl]/ensure: ensure changed 'purged' to 'present'
Notice: /Stage[main]/Php::Extension::Imagick/Php::Extension[imagick]/Package[php5-imagick]/ensure: ensure changed 'purged' to 'present'
Notice: /Stage[main]/Php::Extension::Mysql/Php::Extension[mysql]/Package[php5-mysql]/ensure: ensure changed 'purged' to 'present'
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[xhprof]/Package[pecl.php.net/xhprof-beta]/ensure: created
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[memcached]/Package[pecl.php.net/memcached]/ensure: created
Notice: /Stage[main]/Php::Extension::Mcrypt/Php::Extension[mcrypt]/Package[php5-mcrypt]/ensure: ensure changed 'purged' to 'present'
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[mongo]/Package[pecl.php.net/mongo]/ensure: created
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[apcu]/Package[pecl.php.net/apcu-beta]/ensure: created
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[amqp]/Package[pecl.php.net/amqp-1.2.0]/ensure: created
Notice: /Stage[main]/Php::Extension::Redis/Php::Extension[redis]/Package[php5-redis]/ensure: ensure changed 'purged' to 'present'
Notice: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[uuid]/Package[pecl.php.net/uuid]/ensure: created
Notice: /Stage[main]/Php::Cli/Php::Config[php-cli]/Augeas[php-php-cli-config]/returns: executed successfully
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Notice: Finished catalog run in 1546.21 seconds


Stderr from the command:

stdin: is not a tty
Error: wget --verbose --output-document=/usr/local/src/elasticsearch/elastic-search-0.90.2.deb https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.90.2.deb returned 8 instead of one of [0]
Error: /Stage[main]/Elasticsearch/Wget::Fetch[elasticsearch_deb]/Exec[wget-elasticsearch_deb]/returns: change from notrun to 0 failed: wget --verbose --output-document=/usr/local/src/elasticsearch/elastic-search-0.90.2.deb https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.90.2.deb returned 8 instead of one of [0]
Warning: /Stage[main]/Elasticsearch/Exec[elasticsearch installation]: Skipping because of failed dependencies
Warning: /Stage[main]/Elasticsearch/Service[elasticsearch]: Skipping because of failed dependencies
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-uuid]/Augeas[php-php-extension-uuid-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-xdebug]/Augeas[php-php-extension-xdebug-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-jsmin]/Augeas[php-php-extension-jsmin-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-mongo]/Augeas[php-php-extension-mongo-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-amqp]/Augeas[php-php-extension-amqp-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-apcu]/Augeas[php-php-extension-apcu-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-memcached]/Augeas[php-php-extension-memcached-config]: Could not evaluate: Save failed with return code false, see debug
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Config[php-extension-xhprof]/Augeas[php-php-extension-xhprof-config]: Could not evaluate: Save failed with return code false, see debug
Warning: /Stage[main]/Php::Fpm/Package[php5-fpm]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Fpm/Service[php5-fpm]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Fpm/Php::Config[php-fpm]/Augeas[php-php-fpm-config]: Skipping because of failed dependencies

I don't know how to resolve it.

@sqmk
Owner
sqmk commented Mar 25, 2014

I'll take a look!

@Freyskeyd

here is the full log:

Bringing machine 'default' up with 'virtualbox' provider...
[default] Importing base box 'debian-php-dev'...
[default] Matching MAC address for NAT networking...
[default] Setting the name of the VM...
[default] Clearing any previously set forwarded ports...
[default] Fixed port collision for 22 => 2222. Now on port 2202.
Pruning invalid NFS exports. Administrator privileges will be required...
[default] Creating shared folders metadata...
[default] Clearing any previously set network interfaces...
[default] Preparing network interfaces based on configuration...
[default] Forwarding ports...
[default] -- 22 => 2202 (adapter 1)
[default] -- 80 => 8080 (adapter 1)
[default] Booting VM...
[default] Waiting for machine to boot. This may take a few minutes...
[default] Machine booted and ready!
[default] The guest additions on this VM do not match the installed version of
VirtualBox! In most cases this is fine, but in rare cases it can
cause things such as shared folders to not work properly. If you see
shared folder errors, please update the guest additions within the
virtual machine and reload your VM.

Guest Additions Version: 4.2.10
VirtualBox Version: 4.3
[default] Setting hostname...
[default] Configuring and enabling network interfaces...
[default] Mounting shared folders...
[default] -- /vagrant
[default] -- /tmp/vagrant-puppet/manifests
[default] -- /tmp/vagrant-puppet/modules-0
[default] Exporting NFS shared folders...
Preparing to edit /etc/exports. Administrator privileges will be required...
[default] Mounting NFS shared folders...
[default] Running provisioner: puppet...
Running Puppet with site.pp...
stdin: is not a tty
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[dotdeb]/Apt::Key[Add key: 89DF5277 from Apt::Source dotdeb]/Exec[e1c75b131c45e7244c2d6b1886de1c6f1892f23f]/returns: executed successfully
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[10gen]/Apt::Key[Add key: 7F0CEB10 from Apt::Source 10gen]/Exec[b94ff96203335a23dcd698a0ca82d59bdc9b5292]/returns: executed successfully
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[10gen]/File[10gen.list]/ensure: created
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[dotdeb]/File[dotdeb.list]/ensure: created
Notice: /Stage[preinstall_apt]/Apt::Update/Exec[apt_update]: Triggered 'refresh' from 2 events
Error: Command exceeded timeout
Error: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Exec[apt-get upgrade]/returns: change from notrun to 0 failed: Command exceeded timeout
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Anchor[sqmk::apt::repo::end]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Anchor[sqmk::apt::repo::end]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[subversion]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[subversion]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[libtool]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[libtool]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[libtidy-dev]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[libtidy-dev]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[libcurl4-openssl-dev]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[libcurl4-openssl-dev]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[libmcrypt-dev]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[libmcrypt-dev]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[imagemagick]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[imagemagick]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[yasm]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[yasm]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Wget/Package[wget]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Wget/Package[wget]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[nasm]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[nasm]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[ntp]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[ntp]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[mcrypt]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[mcrypt]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[curl]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[curl]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[autoconf]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[autoconf]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/File[/usr/local/src/librabbitmq]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/File[/usr/local/src/librabbitmq]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Wget::Fetch[wget_librabbitmq]/Exec[wget-wget_librabbitmq]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Wget::Fetch[wget_librabbitmq]/Exec[wget-wget_librabbitmq]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Exec[librabbitmq_install]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Exec[librabbitmq_install]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[tidy]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[tidy]: Skipping because of failed dependencies
Notice: /Stage[preinstall_libs]/Required_libs/Package[libxml++2.6-dev]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[preinstall_libs]/Required_libs/Package[libxml++2.6-dev]: Skipping because of failed dependencies
Notice: /Stage[main]/Gcc/Package[build-essential]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Gcc/Package[build-essential]: Skipping because of failed dependencies
Notice: /Stage[main]/Memcached/Package[memcached]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Memcached/Package[memcached]: Skipping because of failed dependencies
Notice: /Stage[main]/Memcached/Package[libmemcached-dev]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Memcached/Package[libmemcached-dev]: Skipping because of failed dependencies
Notice: /Stage[main]/Java/Package[java]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Java/Package[java]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Dev/Php::Contrib::Base_package[dev]/Package[php5-common]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Dev/Php::Contrib::Base_package[dev]/Package[php5-common]: Skipping because of failed dependencies
Notice: /Stage[main]/Gcc/Package[gcc]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Gcc/Package[gcc]: Skipping because of failed dependencies
Notice: /Stage[main]/Rabbitmq::Server/Package[rabbitmq-server]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Rabbitmq::Server/Package[rabbitmq-server]: Skipping because of failed dependencies
Notice: /Stage[main]/Rabbitmq::Server/File[/etc/rabbitmq]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Rabbitmq::Server/File[/etc/rabbitmq]: Skipping because of failed dependencies
Notice: /Stage[main]/Rabbitmq::Server/File[rabbitmq.config]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Rabbitmq::Server/File[rabbitmq.config]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/File[redis-lib]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/File[redis-lib]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/File[/etc/redis]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/File[/etc/redis]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/File[redis-cli-link]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/File[redis-cli-link]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Packages/Package[augeas-lenses]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Packages/Package[augeas-lenses]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Packages/Package[ruby-augeas]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Packages/Package[ruby-augeas]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Packages/Package[augeas-tools]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Packages/Package[augeas-tools]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Packages/Package[libaugeas0]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Packages/Package[libaugeas0]: Skipping because of failed dependencies
Notice: /Stage[main]/Elasticsearch/File[/usr/local/src/elasticsearch]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Elasticsearch/File[/usr/local/src/elasticsearch]: Skipping because of failed dependencies
Notice: /Stage[main]/Mongodb/Package[mongodb-10gen]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Mongodb/Package[mongodb-10gen]: Skipping because of failed dependencies
Notice: /Stage[main]/Mail_configuration/Package[dovecot-core]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Mail_configuration/Package[dovecot-core]: Skipping because of failed dependencies
Notice: /Stage[main]/Mail_configuration/Package[postfix]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Mail_configuration/Package[postfix]: Skipping because of failed dependencies
Notice: /Stage[main]/Elasticsearch/Wget::Fetch[elasticsearch_deb]/Exec[wget-elasticsearch_deb]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Elasticsearch/Wget::Fetch[elasticsearch_deb]/Exec[wget-elasticsearch_deb]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx/Anchor[nginx::begin]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx/Anchor[nginx::begin]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package/Anchor[nginx::package::begin]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package/Anchor[nginx::package::begin]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package::Debian/Exec[add_nginx_apt_key]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package::Debian/Exec[add_nginx_apt_key]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package::Debian/File[/etc/apt/sources.list.d/nginx.list]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package::Debian/File[/etc/apt/sources.list.d/nginx.list]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package::Debian/Exec[apt_get_update_for_nginx]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package::Debian/Exec[apt_get_update_for_nginx]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package::Debian/Anchor[nginx::apt_repo]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package::Debian/Anchor[nginx::apt_repo]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package::Debian/Package[nginx]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package::Debian/Package[nginx]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Package/Anchor[nginx::package::end]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Package/Anchor[nginx::package::end]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/tmp/nginx.d]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/tmp/nginx.d]: Skipping because of failed dependencies
Notice: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-001]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-001]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/var/nginx]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/var/nginx]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/var/nginx/client_body_temp]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/var/nginx/client_body_temp]: Skipping because of failed dependencies
Notice: /Stage[main]//Nginx::Resource::Location[php-dev.example.com:php]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com:php]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]//Nginx::Resource::Location[php-dev.example.com:php]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com:php]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/tmp/nginx.mail.d]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/tmp/nginx.mail.d]: Skipping because of failed dependencies
Notice: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/Nginx::Resource::Location[php-dev.example.com-default]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com-default]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/Nginx::Resource::Location[php-dev.example.com-default]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com-default]: Skipping because of failed dependencies
Notice: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-699]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-699]: Skipping because of failed dependencies
Notice: /Stage[main]/Memcached/File[/etc/memcached.conf]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Memcached/File[/etc/memcached.conf]: Skipping because of failed dependencies
Notice: /Stage[main]/Memcached/Service[memcached]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Memcached/Service[memcached]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/var/nginx/proxy_temp]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/var/nginx/proxy_temp]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/nginx.conf]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/nginx.conf]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/sites-enabled/default]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/sites-enabled/default]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.mail.d]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.mail.d]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Cli/Package[php5-cli]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Cli/Package[php5-cli]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Composer/Exec[download composer]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Composer/Exec[download composer]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Composer/File[/usr/local/bin/composer]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Composer/File[/usr/local/bin/composer]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/dist]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/dist]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib/php.aug]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib/php.aug]: Skipping because of failed dependencies
Notice: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/tests]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/tests]: Skipping because of failed dependencies
Notice: /Stage[main]/Mongodb/File[/etc/mongod.conf]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Mongodb/File[/etc/mongod.conf]: Skipping because of failed dependencies
Notice: /Stage[main]/Mongodb/Service[mongodb]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Mongodb/Service[mongodb]: Skipping because of failed dependencies
Notice: /Stage[main]/Git/Package[git-core]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Git/Package[git-core]: Skipping because of failed dependencies
Notice: /Stage[main]/Rabbitmq::Server/File[rabbitmq-env.config]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Rabbitmq::Server/File[rabbitmq-env.config]: Skipping because of failed dependencies
Notice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d/proxy.conf]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d/proxy.conf]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-vhosts]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-vhosts]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-mailhosts]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-mailhosts]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx::Service/Service[nginx]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx::Service/Service[nginx]: Skipping because of failed dependencies
Notice: /Stage[main]/Nginx/Anchor[nginx::end]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Nginx/Anchor[nginx::end]: Skipping because of failed dependencies
Notice: /Stage[main]/Elasticsearch/Exec[elasticsearch installation]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Elasticsearch/Exec[elasticsearch installation]: Skipping because of failed dependencies
Notice: /Stage[main]/Elasticsearch/Service[elasticsearch]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Elasticsearch/Service[elasticsearch]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/File[/opt/redis-src]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/File[/opt/redis-src]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Exec[get-redis-pkg]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Exec[get-redis-pkg]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Exec[unpack-redis]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Exec[unpack-redis]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Exec[install-redis]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Exec[install-redis]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-lib-port-6379]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-lib-port-6379]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-init-6379]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-init-6379]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis_port_6379.conf]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis_port_6379.conf]: Skipping because of failed dependencies
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/Service[redis-6379]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/Service[redis-6379]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Dev/Package[php5-dev]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Dev/Package[php5-dev]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Pear/Package[php-pear]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Pear/Package[php-pear]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Pear/Exec[php::pear::auto_discover]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Pear/Exec[php::pear::auto_discover]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Extension::Curl/Php::Extension[curl]/Package[php5-curl]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Extension::Curl/Php::Extension[curl]/Package[php5-curl]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Extension::Imagick/Php::Extension[imagick]/Package[php5-imagick]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Extension::Imagick/Php::Extension[imagick]/Package[php5-imagick]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Extension::Mysql/Php::Extension[mysql]/Package[php5-mysql]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Extension::Mysql/Php::Extension[mysql]/Package[php5-mysql]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Extension::Mcrypt/Php::Extension[mcrypt]/Package[php5-mcrypt]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Extension::Mcrypt/Php::Extension[mcrypt]/Package[php5-mcrypt]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Extension::Redis/Php::Extension[redis]/Package[php5-redis]: Dependency Exec[apt-get upgrade] has failures: true
Warning: /Stage[main]/Php::Extension::Redis/Php::Extension[redis]/Package[php5-redis]: Skipping because of failed dependencies
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[memcached]/Package[pecl.php.net/memcached]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[xdebug]/Package[pecl.php.net/xdebug]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[uuid]/Package[pecl.php.net/uuid]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[jsmin]/Package[pecl.php.net/jsmin-beta]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[mongo]/Package[pecl.php.net/mongo]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[apcu]/Package[pecl.php.net/apcu-beta]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[xhprof]/Package[pecl.php.net/xhprof-beta]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[amqp]/Package[pecl.php.net/amqp-1.2.0]: Provider pecl is not functional on this host
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/amqp-1.2.0] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/jsmin-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/uuid] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/memcached] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/mongo] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/xdebug] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/xhprof-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/apcu-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Warning: /Stage[main]/Php::Fpm/Package[php5-fpm]: Skipping because of failed dependencies
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/amqp-1.2.0] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/jsmin-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/uuid] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/memcached] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/mongo] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/xdebug] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/xhprof-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/apcu-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Warning: /Stage[main]/Php::Fpm/Service[php5-fpm]: Skipping because of failed dependencies
Error: Could not find a suitable provider for augeas
Notice: Finished catalog run in 389.81 seconds
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

puppet apply --hiera_config /vagrant/config/hiera.yaml --modulepath '/etc/puppet/modules:/tmp/vagrant-puppet/modules-0' --manifestdir /tmp/vagrant-puppet/manifests --detailed-exitcodes /tmp/vagrant-puppet/manifests/site.pp || [ $? -eq 2 ]

Stdout from the command:

Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[dotdeb]/Apt::Key[Add key: 89DF5277 from Apt::Source dotdeb]/Exec[e1c75b131c45e7244c2d6b1886de1c6f1892f23f]/returns: executed successfully
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[10gen]/Apt::Key[Add key: 7F0CEB10 from Apt::Source 10gen]/Exec[b94ff96203335a23dcd698a0ca82d59bdc9b5292]/returns: executed successfully
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[10gen]/File[10gen.list]/ensure: created
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Apt::Source[dotdeb]/File[dotdeb.list]/ensure: created
Notice: /Stage[preinstall_apt]/Apt::Update/Exec[apt_update]: Triggered 'refresh' from 2 events
Notice: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Anchor[sqmk::apt::repo::end]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[subversion]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[libtool]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[libtidy-dev]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[libcurl4-openssl-dev]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[libmcrypt-dev]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[imagemagick]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[yasm]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Wget/Package[wget]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[nasm]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[ntp]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[mcrypt]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[curl]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[autoconf]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/File[/usr/local/src/librabbitmq]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Wget::Fetch[wget_librabbitmq]/Exec[wget-wget_librabbitmq]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Exec[librabbitmq_install]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[tidy]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[preinstall_libs]/Required_libs/Package[libxml++2.6-dev]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Gcc/Package[build-essential]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Memcached/Package[memcached]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Memcached/Package[libmemcached-dev]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Java/Package[java]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Dev/Php::Contrib::Base_package[dev]/Package[php5-common]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Gcc/Package[gcc]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Rabbitmq::Server/Package[rabbitmq-server]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Rabbitmq::Server/File[/etc/rabbitmq]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Rabbitmq::Server/File[rabbitmq.config]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/File[redis-lib]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/File[/etc/redis]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/File[redis-cli-link]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Packages/Package[augeas-lenses]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Packages/Package[ruby-augeas]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Packages/Package[augeas-tools]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Packages/Package[libaugeas0]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Elasticsearch/File[/usr/local/src/elasticsearch]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Mongodb/Package[mongodb-10gen]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Mail_configuration/Package[dovecot-core]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Mail_configuration/Package[postfix]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Elasticsearch/Wget::Fetch[elasticsearch_deb]/Exec[wget-elasticsearch_deb]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx/Anchor[nginx::begin]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package/Anchor[nginx::package::begin]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package::Debian/Exec[add_nginx_apt_key]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package::Debian/File[/etc/apt/sources.list.d/nginx.list]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package::Debian/Exec[apt_get_update_for_nginx]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package::Debian/Anchor[nginx::apt_repo]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package::Debian/Package[nginx]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Package/Anchor[nginx::package::end]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/tmp/nginx.d]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-001]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/var/nginx]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/var/nginx/client_body_temp]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]//Nginx::Resource::Location[php-dev.example.com:php]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com:php]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/tmp/nginx.mail.d]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/Nginx::Resource::Location[php-dev.example.com-default]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com-default]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-699]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Memcached/File[/etc/memcached.conf]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Memcached/Service[memcached]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/var/nginx/proxy_temp]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/nginx.conf]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/sites-enabled/default]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.mail.d]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Cli/Package[php5-cli]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Composer/Exec[download composer]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Composer/File[/usr/local/bin/composer]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/dist]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib/php.aug]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/tests]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Mongodb/File[/etc/mongod.conf]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Mongodb/Service[mongodb]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Git/Package[git-core]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Rabbitmq::Server/File[rabbitmq-env.config]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d/proxy.conf]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-vhosts]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-mailhosts]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx::Service/Service[nginx]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Nginx/Anchor[nginx::end]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Elasticsearch/Exec[elasticsearch installation]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Elasticsearch/Service[elasticsearch]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/File[/opt/redis-src]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Exec[get-redis-pkg]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Exec[unpack-redis]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Exec[install-redis]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-lib-port-6379]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-init-6379]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis_port_6379.conf]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Redis/Redis::Instance[redis-default]/Service[redis-6379]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Dev/Package[php5-dev]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Pear/Package[php-pear]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Pear/Exec[php::pear::auto_discover]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Extension::Curl/Php::Extension[curl]/Package[php5-curl]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Extension::Imagick/Php::Extension[imagick]/Package[php5-imagick]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Extension::Mysql/Php::Extension[mysql]/Package[php5-mysql]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Extension::Mcrypt/Php::Extension[mcrypt]/Package[php5-mcrypt]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Extension::Redis/Php::Extension[redis]/Package[php5-redis]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/amqp-1.2.0] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/jsmin-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/uuid] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/memcached] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/mongo] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/xdebug] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/xhprof-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Package[pecl.php.net/apcu-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Package[php5-fpm]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Exec[apt-get upgrade] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-amqp-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/amqp-1.2.0] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/jsmin-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/uuid] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/memcached] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/mongo] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/xdebug] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/xhprof-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Package[pecl.php.net/apcu-beta] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-jsmin-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-uuid-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-memcached-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-mongo-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-xdebug-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-xhprof-config] has failures: true
Notice: /Stage[main]/Php::Fpm/Service[php5-fpm]: Dependency Augeas[php-php-extension-apcu-config] has failures: true
Notice: Finished catalog run in 389.81 seconds


Stderr from the command:

stdin: is not a tty
Error: Command exceeded timeout
Error: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Exec[apt-get upgrade]/returns: change from notrun to 0 failed: Command exceeded timeout
Warning: /Stage[preinstall_apt]/Sqmk::Apt::Repo/Anchor[sqmk::apt::repo::end]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[subversion]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[libtool]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[libtidy-dev]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[libcurl4-openssl-dev]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[libmcrypt-dev]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[imagemagick]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[yasm]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Wget/Package[wget]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[nasm]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[ntp]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[mcrypt]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[curl]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[autoconf]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/File[/usr/local/src/librabbitmq]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Wget::Fetch[wget_librabbitmq]/Exec[wget-wget_librabbitmq]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Exec[librabbitmq_install]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[tidy]: Skipping because of failed dependencies
Warning: /Stage[preinstall_libs]/Required_libs/Package[libxml++2.6-dev]: Skipping because of failed dependencies
Warning: /Stage[main]/Gcc/Package[build-essential]: Skipping because of failed dependencies
Warning: /Stage[main]/Memcached/Package[memcached]: Skipping because of failed dependencies
Warning: /Stage[main]/Memcached/Package[libmemcached-dev]: Skipping because of failed dependencies
Warning: /Stage[main]/Java/Package[java]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Dev/Php::Contrib::Base_package[dev]/Package[php5-common]: Skipping because of failed dependencies
Warning: /Stage[main]/Gcc/Package[gcc]: Skipping because of failed dependencies
Warning: /Stage[main]/Rabbitmq::Server/Package[rabbitmq-server]: Skipping because of failed dependencies
Warning: /Stage[main]/Rabbitmq::Server/File[/etc/rabbitmq]: Skipping because of failed dependencies
Warning: /Stage[main]/Rabbitmq::Server/File[rabbitmq.config]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/File[redis-lib]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/File[/etc/redis]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/File[redis-cli-link]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Packages/Package[augeas-lenses]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Packages/Package[ruby-augeas]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Packages/Package[augeas-tools]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Packages/Package[libaugeas0]: Skipping because of failed dependencies
Warning: /Stage[main]/Elasticsearch/File[/usr/local/src/elasticsearch]: Skipping because of failed dependencies
Warning: /Stage[main]/Mongodb/Package[mongodb-10gen]: Skipping because of failed dependencies
Warning: /Stage[main]/Mail_configuration/Package[dovecot-core]: Skipping because of failed dependencies
Warning: /Stage[main]/Mail_configuration/Package[postfix]: Skipping because of failed dependencies
Warning: /Stage[main]/Elasticsearch/Wget::Fetch[elasticsearch_deb]/Exec[wget-elasticsearch_deb]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx/Anchor[nginx::begin]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package/Anchor[nginx::package::begin]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package::Debian/Exec[add_nginx_apt_key]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package::Debian/File[/etc/apt/sources.list.d/nginx.list]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package::Debian/Exec[apt_get_update_for_nginx]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package::Debian/Anchor[nginx::apt_repo]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package::Debian/Package[nginx]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Package/Anchor[nginx::package::end]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/tmp/nginx.d]: Skipping because of failed dependencies
Warning: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-001]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/var/nginx]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/var/nginx/client_body_temp]: Skipping because of failed dependencies
Warning: /Stage[main]//Nginx::Resource::Location[php-dev.example.com:php]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com:php]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/tmp/nginx.mail.d]: Skipping because of failed dependencies
Warning: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/Nginx::Resource::Location[php-dev.example.com-default]/File[/tmp/nginx.d/php-dev.example.com-500-php-dev.example.com-default]: Skipping because of failed dependencies
Warning: /Stage[main]//Nginx::Resource::Vhost[php-dev.example.com]/File[/tmp/nginx.d/php-dev.example.com-699]: Skipping because of failed dependencies
Warning: /Stage[main]/Memcached/File[/etc/memcached.conf]: Skipping because of failed dependencies
Warning: /Stage[main]/Memcached/Service[memcached]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/var/nginx/proxy_temp]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/nginx.conf]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/sites-enabled/default]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.mail.d]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Cli/Package[php5-cli]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Composer/Exec[download composer]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Composer/File[/usr/local/bin/composer]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/dist]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Augeas/File[/usr/share/augeas/lenses/contrib/php.aug]: Skipping because of failed dependencies
Warning: /Stage[main]/Augeas::Files/File[/usr/share/augeas/lenses/tests]: Skipping because of failed dependencies
Warning: /Stage[main]/Mongodb/File[/etc/mongod.conf]: Skipping because of failed dependencies
Warning: /Stage[main]/Mongodb/Service[mongodb]: Skipping because of failed dependencies
Warning: /Stage[main]/Git/Package[git-core]: Skipping because of failed dependencies
Warning: /Stage[main]/Rabbitmq::Server/File[rabbitmq-env.config]: Skipping because of failed dependencies
Warning: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Config/File[/etc/nginx/conf.d/proxy.conf]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-vhosts]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Service/Exec[rebuild-nginx-mailhosts]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx::Service/Service[nginx]: Skipping because of failed dependencies
Warning: /Stage[main]/Nginx/Anchor[nginx::end]: Skipping because of failed dependencies
Warning: /Stage[main]/Elasticsearch/Exec[elasticsearch installation]: Skipping because of failed dependencies
Warning: /Stage[main]/Elasticsearch/Service[elasticsearch]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/File[/opt/redis-src]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Exec[get-redis-pkg]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Exec[unpack-redis]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Exec[install-redis]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-lib-port-6379]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis-init-6379]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/File[redis_port_6379.conf]: Skipping because of failed dependencies
Warning: /Stage[main]/Redis/Redis::Instance[redis-default]/Service[redis-6379]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Dev/Package[php5-dev]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Pear/Package[php-pear]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Pear/Exec[php::pear::auto_discover]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Extension::Curl/Php::Extension[curl]/Package[php5-curl]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Extension::Imagick/Php::Extension[imagick]/Package[php5-imagick]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Extension::Mysql/Php::Extension[mysql]/Package[php5-mysql]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Extension::Mcrypt/Php::Extension[mcrypt]/Package[php5-mcrypt]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Extension::Redis/Php::Extension[redis]/Package[php5-redis]: Skipping because of failed dependencies
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[memcached]/Package[pecl.php.net/memcached]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[xdebug]/Package[pecl.php.net/xdebug]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[uuid]/Package[pecl.php.net/uuid]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[jsmin]/Package[pecl.php.net/jsmin-beta]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[mongo]/Package[pecl.php.net/mongo]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[apcu]/Package[pecl.php.net/apcu-beta]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[xhprof]/Package[pecl.php.net/xhprof-beta]: Provider pecl is not functional on this host
Error: /Stage[main]/Php_install/Php_main[php-5.5.7]/Php::Extension[amqp]/Package[pecl.php.net/amqp-1.2.0]: Provider pecl is not functional on this host
Warning: /Stage[main]/Php::Fpm/Package[php5-fpm]: Skipping because of failed dependencies
Warning: /Stage[main]/Php::Fpm/Service[php5-fpm]: Skipping because of failed dependencies
Error: Could not find a suitable provider for augeas
@sqmk
Owner
sqmk commented Mar 26, 2014

Are you having internet connection problems on your end? Seems like that is the case.

@Freyskeyd

No connection problems, i've try at work and at home and it's the same things.

I'm on Mac OSX 10.9, running vagrant 1.4.3 and virtualBox 4.3.8

@Feawel
Feawel commented Mar 28, 2014

Hi,

I'm having exactly the same problem.

I'm on Mac OSX 10.9, vagrant 1.4.3 and virtualBox 4.3.8

@caseybecking

I'm having the same issue.

vagrant --version
Vagrant 1.3.5
VBoxManage --version
4.3.10r93012
@rommelxcastro

having the same problem, no solution on this?

@Freyskeyd

try using puphpet

@rommelxcastro

@Freyskeyd actually i'm using puphpet, the problem basically is with the yaml config file, i just edit a line

nginx:
    install: ''

to

nginx:
    install: '1'
@Freyskeyd

i've build my own box with debian7 and php 5.5.

It's working like a charme.

I think i will post it soon

@sqmk
Owner
sqmk commented Apr 23, 2014

Apologies. I'll revisit this.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.