Steve Bazyl sqrrrl

Organizations

@google @googledrive
sqrrrl commented on pull request google/google-auth-library-ruby#28
@sqrrrl

@tbetbetbe Curious - why still require 1.9.3 support? It's officially past EOL as far as ruby-lang.org goes (expired back in Feb.) Is it for jruby …

@sqrrrl
Pub/Sub Error Listing Topic Subscriptions
@sqrrrl

Closing since not a client issue.

@sqrrrl
Is JSON Key file supported?
@sqrrrl

Yes, using https://github.com/google/google-auth-library-ruby. Just requires that you set the environment variable GOOGLE_APPLICATION_CREDENTIALS t…

@sqrrrl
@sqrrrl
@sqrrrl
@sqrrrl
Getting servingLimitExceeded using batch requests
@sqrrrl

Use smaller batches :) Seriously, 1000 is the max size of a batch, but that doesn't mean that the API your calling is going to allow you to make th…

@sqrrrl
@sqrrrl
  • @sqrrrl 17fb9d5
    Move rest of dev dependencies to gemfile, knock version down to 0.9
@sqrrrl
@sqrrrl
  • @sqrrrl 32fb51c
    Hide $.xgafv query from APIs, regen
@sqrrrl
  • @sqrrrl 4b41f43
    Allow user-defined headers in requests via options
@sqrrrl
@sqrrrl
  • @sqrrrl 762181c
    Minor cleanup from rubocop
@sqrrrl
  • @sqrrrl b035bd7
    Clean up some yard errors and api names
@sqrrrl
@sqrrrl
@sqrrrl

That API isn't supported by any of the API clients. It doesn't conform to the conventions used by the other APIs.

@sqrrrl
Safe Browsing Lookup API
@sqrrrl
@sqrrrl
  • @sqrrrl ffdd402
    Disable retries by default, but add recommendation in readme to use them
@sqrrrl
  • @sqrrrl 13b6a73
    Remove some unnecessary APIs
@sqrrrl
  • @sqrrrl c6cba01
    Refactor method name generation, make prettier names for RPC-style AP…
@sqrrrl
  • @sqrrrl 743cb5e
    Addressable too strict with joins - fix URL building with newer APIs …
@sqrrrl

It's a bug in the pubsub API. There's an internal bug filed for this issue.

@sqrrrl
  • @sqrrrl d0c26f5
    Clean up some rubcop issues