Browse files

add_bundler_dependencies is no longer supported

Moved gem dependencies to the gemspec
  • Loading branch information...
1 parent 0faf3b6 commit 6f36bf72247f722fcbe14fe5692b3703b61578a2 @robolson robolson committed May 23, 2011
Showing with 15 additions and 15 deletions.
  1. +1 −9 Gemfile
  2. +9 −3 Gemfile.lock
  3. +5 −3 border_patrol.gemspec
View
10 Gemfile
@@ -1,10 +1,2 @@
source :rubygems
-
-gem "nokogiri", "= 1.4.3.1"
-
-group :development do
- gem "rake", "= 0.8.7"
- gem "rspec", "= 1.3.0"
- gem "progressbar"
-end
-
+gemspec
View
12 Gemfile.lock
@@ -1,3 +1,9 @@
+PATH
+ remote: .
+ specs:
+ border_patrol (0.1.0)
+ nokogiri (= 1.4.3.1)
+
GEM
remote: http://rubygems.org/
specs:
@@ -10,7 +16,7 @@ PLATFORMS
ruby
DEPENDENCIES
- nokogiri (= 1.4.3.1)
+ border_patrol!
progressbar
- rake (= 0.8.7)
- rspec (= 1.3.0)
+ rake
+ rspec (~> 1.3.0)
View
8 border_patrol.gemspec
@@ -1,7 +1,5 @@
# encoding: utf-8
-require 'bundler'
-
Gem::Specification.new do |s|
s.name = "border_patrol"
s.version = File.read("lib/VERSION").strip
@@ -24,5 +22,9 @@ Gem::Specification.new do |s|
s.files = Dir['{lib,spec}/**/*'] + root_files
s.test_files = Dir['spec/**/*']
- s.add_bundler_dependencies
+ s.add_dependency("nokogiri", "1.4.3.1")
+
+ s.add_development_dependency("rake")
+ s.add_development_dependency("rspec", "~> 1.3.0")
+ s.add_development_dependency("progressbar")
end

0 comments on commit 6f36bf7

Please sign in to comment.