Skip to content

SQUID-2021:4 Multiple Issues in HTTP Range header

moderate
yadij published GHSA-pxwq-f3qr-w2xf May 10, 2021

Package

squid (Squid)

Affected versions

2.5.STABLE2-2.7.STABLE9, 3.0-4.1.4, 5.0.1-5.0.5

Patched versions

4.15, 5.0.6

Description

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-31806

Due to an incorrect input validation bug Squid is vulnerable to
a Denial of Service attack against all clients using the proxy.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-31807

Due to an incorrect memory management bug Squid is vulnerable to
a Denial of Service attack against all clients using the proxy.

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-31808

Due to an integer overflow bug Squid is vulnerable to a Denial
of Service attack against all clients using the proxy.


Severity:

These problems all allow a trusted client to perform Denial of
Service when making HTTP Range requests.

The integer overflow problem allows a remote server to perform
Denial of Service when delivering responses to HTTP Range
requests. The issue trigger is a header which can be expected to
exist in HTTP traffic without any malicious intent.

CVSS Score of 8.0
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:P/RL:O/RC:C/CR:X/IR:X/AR:H/MAV:N/MAC:L/MPR:L/MUI:N/MS:C/MC:X/MI:X/MA:H&version=3.1


Updated Packages:

This bug is fixed by Squid versions 4.15 and 5.0.6.

In addition, patches addressing this problem for the stable
releases can be found in our patch archives:

Squid 4:

http://www.squid-cache.org/Versions/v4/changesets/squid-4-e7cf864f938f24eea8af0692c04d16790983c823.patch

Squid 5:

http://www.squid-cache.org/Versions/v5/changesets/squid-5-6bf66733c122804fada7f5839ef5f3b57e57591c.patch

If you are using a prepackaged version of Squid then please refer
to the package vendor for availability information on updated
packages.


Determining if your version is vulnerable:

Squid older than 3.5.28 have not been tested and should be
assumed to be vulnerable.

All Squid-4.x up to and including 4.14 are vulnerable.

All Squid-5.x up to and including 5.0.5 are vulnerable.


Workaround:

There are no workarounds known for these problems.


Contact details for the Squid project:

For installation / upgrade support on binary packaged versions
of Squid: Your first point of contact should be your binary
package vendor.

If you install and build Squid from the original Squid sources
then the squid-users@lists.squid-cache.org mailing list is your
primary support point. For subscription details see
http://www.squid-cache.org/Support/mailing-lists.html.

For reporting of non-security bugs in the latest STABLE release
the squid bugzilla database should be used
http://bugs.squid-cache.org/.

For reporting of security sensitive bugs send an email to the
squid-bugs@lists.squid-cache.org mailing list. It's a closed
list (though anyone can post) and security related bug reports
are treated in confidence until the impact has been established.


Credits:

This vulnerability was discovered by Joshua Rogers of Opera
Software.

Fixed by Alex Rousskov of The Measurement Factory.


Revision history:

2021-03-19 06:49:52 UTC Initial Report of Denial of Service
2021-03-24 08:51:08 UTC Additional Report of Use-After-Free
2021-03-25 21:57:07 UTC Additional Report of integer-overflow


END

GHSA ID

GHSA-pxwq-f3qr-w2xf

CVSS Score

6.5 Moderate
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H