Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Latest Source Version (1.0.3) Published to PyPi Does Not Build #164

Closed
copperlight opened this issue Feb 16, 2017 · 3 comments
Closed

Latest Source Version (1.0.3) Published to PyPi Does Not Build #164

copperlight opened this issue Feb 16, 2017 · 3 comments
Assignees
Labels
Milestone

Comments

@copperlight
Copy link

copperlight commented Feb 16, 2017

Description

The latest source version (1.0.3) published to PyPi does not build and install.

https://pypi.python.org/simple/mkdocs-material/

The wheel that is published for the same version does install successfully.

We have a repackaging system for distributing Python artifacts that depends on successful source builds.

Expected behavior

A successful build and install from the source package available on PyPi.

Actual behavior

Traceback (most recent call last):
  File "setup.py", line 25, in <module>
    with open("package.json") as data:
IOError: [Errno 2] No such file or directory: 'package.json'

Steps to reproduce the bug

curl -s -o mkdocs-material-1.0.3.tar.gz 'https://pypi.python.org/packages/50/0e/5e821bb0232595e70833328bd44b8cf15fe35cdc75a262221f8248b6f5bf/mkdocs-material-1.0.3.tar.gz#md5=b14be24a0b37bc357efd6553d79e2ce0'
tar xvf mkdocs-material-1.0.3.tar.gz 
cd mkdocs-material-1.0.3
python setup.py

Package versions

  • Python: Python 2.7.11
  • MkDocs: mkdocs, version 0.16.1
  • Material: not installed

System information

  • OS: macOS Sierra 10.12.3
  • Browser: n/a
@squidfunk
Copy link
Owner

squidfunk commented Feb 16, 2017

I changed how the metadata for the package is obtained in the last release. Will fix it and supply a bugfix release.

@squidfunk squidfunk self-assigned this Feb 16, 2017
@squidfunk squidfunk added the bug label Feb 16, 2017
@squidfunk squidfunk added this to the 1.0.4 milestone Feb 16, 2017
@squidfunk
Copy link
Owner

squidfunk commented Feb 16, 2017

Fixed with 1.0.4

@copperlight
Copy link
Author

copperlight commented Feb 16, 2017

Nice, thanks for the quick fix. :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

2 participants