Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 36 lines (28 sloc) 1.178 kb
e60e221 @sreeix Gemifying it
authored
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3 require "couchup/version"
4
5 Gem::Specification.new do |s|
6 s.name = "couchup"
7 s.version = Couchup::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ["V Sreekanth"]
10 s.email = ["sreeix@gmail.com"]
9c7ae3c @sreeix Minor fixes
authored
11 s.homepage = "http://blog.activesphere.com/introducing-couchup-an-interactive-couchdb-co"
64519b4 @sreeix Fixing the typo
authored
12 s.summary = %q{Command line interface to a couchdb deployment.}
13 s.description = %q{Command line interface to a couchdb deployment.}
e60e221 @sreeix Gemifying it
authored
14
15 s.rubyforge_project = "couchup"
16
17 s.files = `git ls-files`.split("\n")
18 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
19 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
9c7ae3c @sreeix Minor fixes
authored
20 s.default_executable = "couchup"
6e3a255 @sreeix Updating the gem and fixing the dependencies
authored
21
e60e221 @sreeix Gemifying it
authored
22 s.require_paths = ["lib"]
6e3a255 @sreeix Updating the gem and fixing the dependencies
authored
23
24
25 s.add_dependency('couchrest')
26 s.add_dependency('yajl-ruby')
27 s.add_dependency('json')
28 s.add_dependency('mime-types')
29 s.add_dependency('rest-client')
ba5005b @sreeix Change to awesome_print instead awesome-print.
authored
30 s.add_dependency('awesome_print')
6e3a255 @sreeix Updating the gem and fixing the dependencies
authored
31
32 s.add_development_dependency('rspec', '1.3.0')
33 s.add_development_dependency('rake')
34 s.add_development_dependency('bundler')
e60e221 @sreeix Gemifying it
authored
35 end
Something went wrong with that request. Please try again.