Permalink
Browse files

Merge pull request #5 from venkateshs/master

Clean up of maven dependencies and allowing hadoop version to be overridable.
  • Loading branch information...
2 parents b3b2038 + 525caac commit bbf6950203fd4995d1f1fa4c02073104e4d8f18a Shwetha G S committed Feb 4, 2013
Showing with 709 additions and 454 deletions.
  1. +14 −0 .gitignore
  2. +18 −6 client/pom.xml
  3. +12 −23 common/pom.xml
  4. +28 −24 feed/pom.xml
  5. +63 −68 messaging/pom.xml
  6. +7 −3 metrics/pom.xml
  7. +16 −18 oozie/pom.xml
  8. +396 −114 pom.xml
  9. +2 −25 prism/pom.xml
  10. +20 −23 process/pom.xml
  11. +25 −19 replication/pom.xml
  12. +41 −44 rerun/pom.xml
  13. +35 −31 retention/pom.xml
  14. +24 −25 test-util/pom.xml
  15. +8 −31 webapp/pom.xml
View
@@ -0,0 +1,14 @@
+# Maven
+target
+
+# IntelliJ
+*.iml
+*.ipr
+*.iws
+.idea
+
+# Eclipse
+.classpath
+.project
+.settings
+
View
@@ -17,7 +17,8 @@
limitations under the License.
-->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
@@ -30,33 +31,44 @@
<description>Ivory CLI client</description>
<name>Ivory CLI client</name>
<packaging>jar</packaging>
+
<dependencies>
<dependency>
<groupId>com.thoughtworks.xstream</groupId>
<artifactId>xstream</artifactId>
- <version>1.3.1</version>
</dependency>
+
<dependency>
<groupId>commons-cli</groupId>
<artifactId>commons-cli</artifactId>
- <version>1.2</version>
</dependency>
+
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
- <version>1.4</version>
</dependency>
+
<dependency>
<groupId>com.sun.jersey</groupId>
<artifactId>jersey-client</artifactId>
- <version>1.9</version>
</dependency>
+
<dependency>
<groupId>com.sun.jersey</groupId>
<artifactId>jersey-json</artifactId>
- <version>1.9</version>
+ </dependency>
+
+ <dependency>
+ <groupId>log4j</groupId>
+ <artifactId>log4j</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.testng</groupId>
+ <artifactId>testng</artifactId>
</dependency>
</dependencies>
+
<build>
<plugins>
<plugin>
View
@@ -29,77 +29,66 @@
<dependency>
<groupId>commons-beanutils</groupId>
<artifactId>commons-beanutils</artifactId>
- <version>1.8.3</version>
</dependency>
+
<dependency>
<groupId>commons-lang</groupId>
<artifactId>commons-lang</artifactId>
- <version>2.1</version>
</dependency>
+
<dependency>
<groupId>org.apache.hadoop</groupId>
<artifactId>hadoop-test</artifactId>
- <version>0.20.2-cdh3u0</version>
- <scope>test</scope>
</dependency>
+
<dependency>
<groupId>org.apache.ivory</groupId>
<artifactId>ivory-client</artifactId>
- <version>${project.version}</version>
</dependency>
+
<dependency>
<groupId>org.apache.ivory</groupId>
<artifactId>ivory-metrics</artifactId>
- <version>${project.version}</version>
</dependency>
+
<dependency>
<groupId>javax.xml.bind</groupId>
<artifactId>jaxb-api</artifactId>
- <version>2.1</version>
- <scope>compile</scope>
</dependency>
+
<dependency>
<groupId>org.apache.hadoop</groupId>
<artifactId>hadoop-core</artifactId>
- <version>0.20.2-cdh3u0</version>
- <exclusions>
- <exclusion>
- <groupId>org.eclipse.jdt</groupId>
- <artifactId>core</artifactId>
- </exclusion>
- </exclusions>
</dependency>
+
<dependency>
<groupId>org.testng</groupId>
<artifactId>testng</artifactId>
- <version>6.1.1</version>
- <scope>test</scope>
</dependency>
+
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
- <version>1.2</version>
</dependency>
+
<dependency>
<groupId>org.codehaus.jettison</groupId>
<artifactId>jettison</artifactId>
- <version>1.3</version>
</dependency>
+
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-jms</artifactId>
- <version>3.0.3.RELEASE</version>
</dependency>
+
<dependency>
<groupId>org.springframework</groupId>
<artifactId>spring-beans</artifactId>
- <version>3.0.3.RELEASE</version>
</dependency>
+
<dependency>
<groupId>org.apache.ivory</groupId>
<artifactId>ivory-test-util</artifactId>
- <version>${project.version}</version>
- <scope>test</scope>
</dependency>
</dependencies>
View
@@ -17,7 +17,8 @@
limitations under the License.
-->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
@@ -31,28 +32,31 @@
<name>Ivory Feed</name>
<packaging>jar</packaging>
- <dependencies>
- <dependency>
- <groupId>org.apache.ivory</groupId>
- <artifactId>ivory-common</artifactId>
- <version>${project.version}</version>
- </dependency>
- <dependency>
- <groupId>org.apache.ivory</groupId>
- <artifactId>ivory-oozie-adaptor</artifactId>
- <version>${project.version}</version>
- </dependency>
- <dependency>
- <groupId>org.apache.ivory</groupId>
- <artifactId>ivory-messaging</artifactId>
- <version>${project.version}</version>
- </dependency>
- <dependency>
- <groupId>org.apache.ivory</groupId>
- <artifactId>ivory-test-util</artifactId>
- <version>${project.version}</version>
- <scope>test</scope>
- </dependency>
- </dependencies>
+ <dependencies>
+ <dependency>
+ <groupId>org.apache.ivory</groupId>
+ <artifactId>ivory-common</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.apache.ivory</groupId>
+ <artifactId>ivory-oozie-adaptor</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.apache.ivory</groupId>
+ <artifactId>ivory-messaging</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.apache.ivory</groupId>
+ <artifactId>ivory-test-util</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.testng</groupId>
+ <artifactId>testng</artifactId>
+ </dependency>
+ </dependencies>
</project>
View
@@ -11,74 +11,69 @@
OF ANY KIND, either express or implied. See the License for the specific
language governing permissions and limitations under the License. -->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+ xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
- <modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.apache.ivory</groupId>
- <artifactId>ivory-main</artifactId>
- <version>0.2-SNAPSHOT</version>
- </parent>
- <artifactId>ivory-messaging</artifactId>
- <description>Ivory JMS messaging Module</description>
- <name>Ivory Messaging</name>
- <packaging>jar</packaging>
- <dependencies>
- <dependency>
- <groupId>org.apache.activemq</groupId>
- <artifactId>activemq-core</artifactId>
- <version>5.4.3</version>
- <exclusions>
- <exclusion>
- <groupId>com.ibm.icu</groupId>
- <artifactId>icu4j</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
- <dependency>
- <groupId>org.apache.hadoop</groupId>
- <artifactId>hadoop-core</artifactId>
- <version>0.20.2-cdh3u0</version>
- <exclusions>
- <exclusion>
- <groupId>org.eclipse.jdt</groupId>
- <artifactId>core</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
- <dependency>
- <groupId>org.apache.hadoop</groupId>
- <artifactId>hadoop-test</artifactId>
- <version>0.20.2-cdh3u0</version>
- <scope>test</scope>
- </dependency>
- </dependencies>
- <build>
- <plugins>
-<!-- <plugin>
- <groupId>org.apache.maven.plugins</groupId>
- <artifactId>maven-shade-plugin</artifactId>
- <version>1.5</version>
- <executions>
- <execution>
- <phase>package</phase>
- <goals>
- <goal>shade</goal>
- </goals>
- <configuration>
- <finalName>ivory-messaging-execution-jar</finalName>
- <transformers>
- <transformer
- implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
- <mainClass>org.apache.ivory.messaging.MessageProducer</mainClass>
- </transformer>
- </transformers>
- </configuration>
- </execution>
- </executions>
- </plugin> -->
- </plugins>
- </build>
+ <modelVersion>4.0.0</modelVersion>
+ <parent>
+ <groupId>org.apache.ivory</groupId>
+ <artifactId>ivory-main</artifactId>
+ <version>0.2-SNAPSHOT</version>
+ </parent>
+ <artifactId>ivory-messaging</artifactId>
+ <description>Ivory JMS messaging Module</description>
+ <name>Ivory Messaging</name>
+ <packaging>jar</packaging>
+
+ <dependencies>
+ <dependency>
+ <groupId>org.apache.activemq</groupId>
+ <artifactId>activemq-core</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.apache.hadoop</groupId>
+ <artifactId>hadoop-core</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.apache.hadoop</groupId>
+ <artifactId>hadoop-test</artifactId>
+ </dependency>
+
+ <dependency>
+ <groupId>org.testng</groupId>
+ <artifactId>testng</artifactId>
+ </dependency>
+ </dependencies>
+ <build>
+ <plugins>
+ <!--
+ <plugin>
+ <groupId>org.apache.maven.plugins</groupId>
+ <artifactId>maven-shade-plugin</artifactId>
+ <version>1.5</version>
+ <executions>
+ <execution>
+ <phase>package</phase>
+ <goals>
+ <goal>shade</goal>
+ </goals>
+ <configuration>
+ <finalName>ivory-messaging-execution-jar</finalName>
+ <transformers>
+ <transformer
+ implementation="org.apache.maven.plugins.shade.resource.ManifestResourceTransformer">
+ <mainClass>org.apache.ivory.messaging.MessageProducer</mainClass>
+ </transformer>
+ </transformers>
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
+ -->
+ </plugins>
+ </build>
</project>
View
@@ -17,7 +17,8 @@
limitations under the License.
-->
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
+<project xmlns="http://maven.apache.org/POM/4.0.0"
+ xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
@@ -36,13 +37,16 @@
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjrt</artifactId>
- <version>1.6.11</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjweaver</artifactId>
- <version>1.6.11</version>
+ </dependency>
+
+ <dependency>
+ <groupId>log4j</groupId>
+ <artifactId>log4j</artifactId>
</dependency>
</dependencies>
</project>
Oops, something went wrong.

0 comments on commit bbf6950

Please sign in to comment.