Skip to content
Permalink
Browse files

build: clarify support for Node.js Active LTS

In the past the install file said we supported v6+ but Travis only ran
tests for Node 10. I think it would be great to support older versions
of Node when possible but that since we don't have many resources for
maintenance and support we should clarify that this is only guaranteed
to work on the Node.js Active LTS release (currently Node 10).
  • Loading branch information...
christianbundy committed Jun 18, 2019
1 parent 82f06c8 commit db1d4a86f807a53138d5b68806729a738b407794
Showing with 6 additions and 5 deletions.
  1. +3 −3 .travis.yml
  2. +3 −2 docs/INSTALL.md
@@ -3,18 +3,18 @@ matrix:
- os: osx
osx_image: xcode9.4
language: node_js
node_js: 10
node_js: lts/*
env:
- ELECTRON_CACHE=$HOME/.cache/electron
- ELECTRON_BUILDER_CACHE=$HOME/.cache/electron-builder

- os: linux
language: node_js
node_js: 10
node_js: lts/*

- os: windows
language: node_js
node_js: 10
node_js: lts/*
filter_secrets: false

cache:
@@ -3,11 +3,10 @@
The readme contains some information on the simplest installation methods, but
you can also install Patchwork by fetching from Git and building from source.


## Dependencies

- Git
- Node.js (>= 6)
- Node.js ([Active LTS][node-active-lts])
- npm or Yarn

### Debian / Ubuntu
@@ -63,3 +62,5 @@ With yarn:
```shell
yarn
```

[node-active-lts]: https://github.com/nodejs/Release#release-schedule

0 comments on commit db1d4a8

Please sign in to comment.
You can’t perform that action at this time.