New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't install: Unsupported URL Type: github:ssbc #671

Closed
dpc opened this Issue Nov 13, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@dpc

dpc commented Nov 13, 2017

> npm update
npm ERR! Linux 4.13.9-200.fc26.x86_64
npm ERR! argv "/home/dpc/opt/bin/node" "/home/dpc/opt/bin/npm" "update"
npm ERR! node v0.12.0
npm ERR! npm  v2.5.1

npm ERR! Unsupported URL Type: github:ssbc/chloride#4492abb5186c03146a546eb4e5aab326474781fa
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /home/dpc/tmp/patchwork/npm-debug.log

Do I need to install something?

@mmckegg

This comment has been minimized.

Show comment
Hide comment
@mmckegg

mmckegg Nov 13, 2017

Member

Yep, looks you need to upgrade to a newer version of npm (and probably node).

Just noticed that on the readme, it says npm >= 2, but it should be 3.

Member

mmckegg commented Nov 13, 2017

Yep, looks you need to upgrade to a newer version of npm (and probably node).

Just noticed that on the readme, it says npm >= 2, but it should be 3.

mmckegg added a commit that referenced this issue Nov 13, 2017

@dpc

This comment has been minimized.

Show comment
Hide comment
@dpc

dpc Nov 13, 2017

This is it, I guess. I'm on Fedora 26 and have npm 2.5.1. Thank you for help!

dpc commented Nov 13, 2017

This is it, I guess. I'm on Fedora 26 and have npm 2.5.1. Thank you for help!

@dpc dpc closed this Nov 13, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment