Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

remove dev deps

  • Loading branch information...
commit 7895a62f1747f372dc29126b4e430bad1065b517 1 parent c87c363
@stereobooster stereobooster authored
Showing with 4 additions and 21 deletions.
  1. +4 −2 Gemfile
  2. +0 −19 execjs.gemspec
View
6 Gemfile
@@ -3,11 +3,13 @@ source :rubygems
gemspec
group :test do
- gem 'johnson', :platform => :mri_18
gem 'json'
+ # see https://github.com/jbarnette/johnson/issues/21
+ gem 'johnson', :platform => :mri_18
# see https://github.com/nu7hatch/mustang/issues/18
gem 'mustang', :platform => :ruby,
:git => "https://github.com/nu7hatch/mustang.git", :ref => "2a3bcfbd9fd0f34e9b004fcd92188f326b40ec2a"
+ # disabled for rbx, because of https://github.com/cowboyd/therubyracer/issues/157
gem 'therubyracer', :platform => :mri
- gem 'therubyrhino', :platform => :jruby
+ gem 'therubyrhino', ">=1.73.3", :platform => :jruby
end
View
19 execjs.gemspec
@@ -14,25 +14,6 @@ Gem::Specification.new do |s|
s.add_dependency "multi_json", "~>1.0"
s.add_development_dependency "rake"
- # mri_18
- if (!defined?(RUBY_ENGINE) || RUBY_ENGINE == "ruby") && RUBY_VERSION < "1.9"
- # see https://github.com/jbarnette/johnson/issues/21
- s.add_development_dependency "johnson"
- end
-
- # mri
- if (!defined?(RUBY_ENGINE) || RUBY_ENGINE == "ruby")
- # disabled for rbx, because of https://github.com/cowboyd/therubyracer/issues/157
- s.add_development_dependency "therubyracer"
- end
-
- # jruby
- if (defined?(RUBY_ENGINE) && RUBY_ENGINE == "jruby")
- s.add_development_dependency "therubyrhino", ">=1.73.3"
- else
- s.add_development_dependency "mustang"
- end
-
s.authors = ["Sam Stephenson", "Josh Peek"]
s.email = ["sstephenson@gmail.com", "josh@joshpeek.com"]
end
Please sign in to comment.
Something went wrong with that request. Please try again.