Skip to content
This repository

Ruby-build not detecting gcc #72

Closed
bradly opened this Issue · 2 comments

3 participants

Bradly Feeley Joshua Peek Sorin Ionescu
Bradly Feeley

Installed rbenv and ruby-build today and when I try and install a Ruby I get an error that a suitable gcc binary couldn't be found.

~ $ rbenv install 1.9.2-p290

ERROR: This package must be compiled with GCC, and we
couldn't find a suitable `gcc' binary on your system.
Please install GCC and try again.

You can install these GCC packages on Mac OS X:
https://github.com/kennethreitz/osx-gcc-installer/downloads


BUILD FAILED

Inspect or clean up the working tree at /var/folders/df/2c1r37kd52l_5t54bb25xwt80000gn/T/ruby-build.20111023123010.330

 ~ $ which gcc
/usr/bin/gcc

 ~ $ gcc
i686-apple-darwin11-llvm-gcc-4.2: no input files

 ~ $ ruby-build
ruby-build 20110928
usage: ruby-build [-v|--verbose] definition prefix
       ruby-build --definitions
Joshua Peek

1.9.2 isn't compatible with lllvm-gcc. You need to download "real gcc" from that link.

Joshua Peek josh closed this
Sorin Ionescu

Ruby 1.9.3-p0 compiles fine with the following commented out in verify_gcc.

  if echo "$version" | grep LLVM >/dev/null; then
    return 1
  fi

#87 handles better.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.