Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tests run successfully with non-existent browser specified in stjs-test.properties #97

Closed
lumixen opened this issue Aug 3, 2015 · 0 comments

Comments

@lumixen
Copy link
Contributor

commented Aug 3, 2015

For example, if I specify in stjs-test.properties a non-existent browser stjs.test.browsers=Oops then stj-js tests runner reports that all tests are ran successfully.
Output is looks following:

T E S T S    
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was  removed in 8.0
Running a.b.c.Test
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.422 sec
...
Unable to create browser "Oops": Unknown browser name
...
Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.041 sec
Running a.b.y.Test2
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.001 sec

Results :
Tests run: 5, Failures: 0, Errors: 0, Skipped: 18
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------

@onigoetz onigoetz added the Bug label Aug 4, 2015

@npiguet npiguet closed this in e137126 Aug 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.