Permalink
Browse files

Relax requirements.txt to allow ansible 2.3

Kayobe has a dependency on ansible, which is currently capped to 2.2. Docker has
decided to rename the docker-py python module to docker, and made some backwards
incompatible API changes to go along with it. Kolla-ansible requires us to use
docker (not docker-py) on the target hosts, but this is not supported for the
docker_container and docker_image ansible modules that kayobe uses with ansible
2.2. Upgrading to ansible 2.3 allows us to support the new docker python package.
  • Loading branch information...
markgoddard committed Sep 13, 2017
1 parent a8f95c9 commit c2312561dd9b3c45b7846a8dd59ff53f9a7695ef
Showing with 1 addition and 1 deletion.
  1. +1 −1 requirements.txt
View
@@ -1,4 +1,4 @@
ansible<2.3.0 # GPLv3
ansible<2.4.0 # GPLv3
cliff>=2.5.0 # Apache
netaddr!=0.7.16,>=0.7.13 # BSD
PyYAML>=3.10.0 # MIT

0 comments on commit c231256

Please sign in to comment.