Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Issues with pinned tab in Firefox #546

Open
louno opened this issue May 7, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@louno
Copy link

commented May 7, 2019

Hi all,

While pinned tab were perfectly working with Google Chrome, every morning Firefox display an error and all my notes will be blank until I refresh standardnotes tab. Do you have any idea why ? Am I the only one to face this issue (Extensions related issue maybe ?)

Thanks for your help,

2019-05-07 08_01_39-Notes — Standard Notes _ https___app standardnotes org_

@mobitar

This comment has been minimized.

Copy link
Member

commented May 7, 2019

Strangely enough someone just mentioned this 2 days ago: standardnotes/web#240 (comment)

I personally haven't been able to replicate it though. It seems like some kind of elapsed time is required. Can you try to describe your replication steps?

@louno

This comment has been minimized.

Copy link
Author

commented May 7, 2019

Hi Mo,

Thanks for your message and sorry i searched for "Firefox pinned" and that didn't send back the previous topic. Sorry.

Steps :

  1. Standard Notes is pinned in Firefox and works fine
  2. Close firefox
  3. Start Firefox
  4. Standard notes display error and every notes are blank
  5. Refresh tabs
  6. Standard notes now works fine

However, seems that disconnect/reconnect, as suggested in the other topic fixed the issue !

Thanks for your help !

@mobitar

This comment has been minimized.

Copy link
Member

commented May 8, 2019

I just tested these steps, and I was actually able to replicate it once. But only once. I tried 20 more times after that, but it wouldn't happen. I'd need to consistently be able to replicate it to have a chance at a fix. Does this happen for you 100% of the time, or less?

I'm on macOS btw, so my flow is:

  1. Open Firefox, open web app, pin the tab
  2. Open another tab and go to any website.
  3. Close the app by clicking X. On mac this keeps the app running in the background still, but all tabs would be closed.
  4. Re-open app by clicking Firefox in dock.
  5. Firefox starts in "New tab" page, with SN tab to the left.
  6. Choose SN tab, content loads and works fine.

Let me know if there's anything you think I can do to get it to reproduce again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.