Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

option to clear HTML markup when switching from Bold editor to Plain editor? #652

Open
johnmahoney opened this issue Aug 7, 2019 · 3 comments

Comments

@johnmahoney
Copy link

commented Aug 7, 2019

I was just experimenting with the Bold editor, and found that any note I create with it has some form of HTML markup (paragraph tags, etc). If I then switch to the plain editor, all of this markup is visible.

Is there a way to to convert back to truly plain text when switching editors? Or another preferred method to pull plain text from a note created with the Bold editor?

@bryvin

This comment has been minimized.

Copy link

commented Aug 7, 2019

There isn't a direct way to convert back to plain text only, but my suggestion would be to first copy the text while in the Bold Editor (ctrl/cmd+a, ctrl/cmd+c) then switch to the plain editor and replace all the HTML with what you just copied (ctrl/cmd+a, ctrl/cmd+v).

This will place the text in regular format as expected and leaves line breaks in tact.

Note: There is no way to switch back and forth however; once you switch back to plain text and overwrite the HTML, your formatting will be lost and you cannot go back to the HTML version unless you switch to Bold editor and re-format manually.

@johnmahoney

This comment has been minimized.

Copy link
Author

commented Aug 7, 2019

@bryvin That seems like a sensible workaround, thanks. You could also use Session History to revert back to the formatted version if you needed to, I realize (losing any subsequent changes you made after "converting" to plain text of course).

@MorgothSauron

This comment has been minimized.

Copy link

commented Aug 12, 2019

@bryvin Copy/paste works partially if I have image attached from FileSafe. I get the text, but when I paste I don't have the link to the image.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.