Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Catalina: New install of SN app won't open in Catalina #715

Open
krgp21 opened this issue Oct 5, 2019 · 8 comments

Comments

@krgp21
Copy link

commented Oct 5, 2019

"The application “Standard Notes.app” can’t be opened."

Other users having same problem in Reddit. Am using 10.15 Beta (19A582a).

Thanks.

@krgp21

This comment has been minimized.

Copy link
Author

commented Oct 6, 2019

Update: I downloaded .15 from GH and it launched fine. It's .16 that seems to be the problem.

@ebaines3

This comment has been minimized.

Copy link

commented Oct 7, 2019

I experienced the same thing. Version 3.0.16 of SN would not open a fresh on a fresh install of the release version of Catalina, yet version 3.0.15 does open.

@sschultze

This comment has been minimized.

Copy link

commented Oct 10, 2019

I experienced the same with version 3.0.17. Does not open. Downloaded and installed version 3.0.15 and everything works fine.

@mobitar

This comment has been minimized.

Copy link
Member

commented Oct 10, 2019

Hoping to investigate this sometime this week or early next.

@ebaines3

This comment has been minimized.

Copy link

commented Oct 10, 2019

If it's helpful, I've had this same issue with a few other Electron apps (Signal, for instance). You may already be beyond this point, but here's a link to a fix that may work. Thank you so much for all your work!

https://medium.com/cacher-app/getting-your-electron-app-working-on-macos-catalina-10-15-63e53f397da2

@mobitar

This comment has been minimized.

Copy link
Member

commented Oct 10, 2019

Nice find, thanks for the resource! This may come in handy.

@mobitar

This comment has been minimized.

Copy link
Member

commented Oct 15, 2019

Related thread: standardnotes/desktop#399 (comment)

One user said:

Scratch that, installing 3.0.17 from the github releases page fixed it for me. Not sure how that differs from the version on standardnotes..org.

Not sure if anyone can replicate. Downloads from our site are also served from GitHub, so shouldn't really make a difference.

@mobitar

This comment has been minimized.

Copy link
Member

commented Oct 16, 2019

It looks like downloading from zip doesn't work, but download as dmg from the releases page works.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.